Electronics

Electronics

Can’t run electromagnetics in AIM

    • ECEPSU
      Subscriber

      Something is wrong with the solver settings in the Electromagnetics when I select frequency response. I get the error:

      "Unsupported type for creation: SkinDepthResolution

      Parameter name: entityType"

      With details

      "at Microsoft.Scripting.Runtime.BinderOps.InvokeMethod(MethodBase mb, Object obj, Object[] args)

      at Microsoft.Scripting.Interpreter.FuncCallInstruction`4.Run(InterpretedFrame frame)

      at Microsoft.Scripting.Interpreter.Interpreter.Run(InterpretedFrame frame)

      at Microsoft.Scripting.Interpreter.LightLambda.Run5[T0,T1,T2,T3,T4,TRet](T0 arg0, T1 arg1, T2 arg2, T3 arg3, T4 arg4)

      at System.Dynamic.UpdateDelegates.UpdateAndExecute4[T0,T1,T2,T3,TRet](CallSite site, T0 arg0, T1 arg1, T2 arg2, T3 arg3)

      at Microsoft.Scripting.Interpreter.DynamicInstruction`5.Run(InterpretedFrame frame)

      at Microsoft.Scripting.Interpreter.Interpreter.Run(InterpretedFrame frame)

      at Microsoft.Scripting.Interpreter.LightLambda.Run3[T0,T1,T2,TRet](T0 arg0, T1 arg1, T2 arg2)

      at System.Dynamic.UpdateDelegates.UpdateAndExecute4[T0,T1,T2,T3,TRet](CallSite site, T0 arg0, T1 arg1, T2 arg2, T3 arg3)

      at Microsoft.Scripting.Interpreter.DynamicInstruction`5.Run(InterpretedFrame frame)

      at Microsoft.Scripting.Interpreter.Interpreter.Run(InterpretedFrame frame)

      at Microsoft.Scripting.Interpreter.LightLambda.Run2[T0,T1,TRet](T0 arg0, T1 arg1)

      at System.Dynamic.UpdateDelegates.UpdateAndExecute2[T0,T1,TRet](CallSite site, T0 arg0, T1 arg1)"

       

      And my physics selections and regions are never valid, potentially due to this.I can't run electromagnetic simulations, even when its the only one listed. I'm using aim, gonna try the old UI.

      I can't run any electromagnetic solutions

    • pgl
      Ansys Employee

      Can you please provide a bit more detail on the analysis you are trying to perform and a screenshot of your physics settings?  

      My assumption at this point is that you are interested in an Eddy Effect Computation? This is available for Physics Regions with the Physics type set to Electromagnetics and the Physics Calculation type set to Frequency response. From the product manual section " Physics > Physics Options > Eddy Effect Computation" : 

      Eddy Effect Computation allows you to control both Eddy effect and Displacement current computations for the conductors in an electromagnetics frequency response design. Eddy effect refers to current flow (eddy currents) induced by a time-varying magnetic field in conductors; while displacement current refers to currents due to a time-varying electric field. The effects of these currents on the solution tend to be more significant at higher frequencies.

      To control Eddy effect and displacement current computations:

      Select an option for how Eddy effect computation is applied. The default is Program controlled, which automatically selects all conductors for the computation, or you can explicitly choose from the following:

      • User defined, which enables you to select the conductors you want to include. Note: Eddy effect computation must only include conductors.
      • Off, which instructs the solver not to perform Eddy current calculations.

      Select an option for how Displacement current computation is applied. The default is Program controlled, which automatically selects all conductors for the computation, or you can explicitly choose from the following:

      • User defined, which enables you to select the objects you want to include. Note: Conductors selected for Displacement current computation must also be selected for Eddy effect computation. You can choose to apply Displacement current computation alone for non-conductors you select.
      • Off, which instructs the solver not to perform displacement current calculations.

       

    • ECEPSU
      Subscriber

      Thank you for you response! Yes I am trying to simulate a high frequency response in a small Copper wire. I'd also like to include structural and thermal analysis when possible. I've included some screenshots below.

      Where do you find this setting: " Physics > Physics Options > Eddy Effect Computation"? I'm not sure if the "the product manual section" is what I'm looking at in my screenshots  I'll look for it elsewhere in the mean time but I did not see it under physics in my first screenshot

      I see solver options but there's nothing available:

      Thanks!

      Alec

       

    • ECEPSU
      Subscriber

      I've tried only using the Electromagnetics as the only "physics type" and I keep running into this error (see image). The program doesn't elaborate on why the combination is invalid

    • ECEPSU
      Subscriber

      I want to clarify that I am mostly interested in the skin effect in Copper, as well as other materials. I need to verify that ANSYS is capable of modelling the skin effect at high frequencies.

       

      But I can't seem to get the electromagnetics template working no matter what I do!

    • pgl
      Ansys Employee

      Here's how to access the help system and product doc. 

      Scroll down the LHS menu for the sections I mentioned above, or use the Search feature. That will answer your questions on the electromagnetics simulation. 

      Make sure you are using the 18.1 product also. 

    • ECEPSU
      Subscriber

      I appreciate the resource, however I still don't see these settings anywhere. For example Physics > Physics Options > Torque Computation and Physics > Settings > Frequency Response

      Am I looking in the wrong place for options and settings? I'm not sure where else they could be, or why my physics regions are considered to be invalid.

      Do I need to resolve the physics regions before these options are available? I've tried with and without an air enclosure, and still no luck. I don't know why "Electromagnetics" is still not a valid option:

      No such section Physics > Physics Options

      Thank you

       

    • ECEPSU
      Subscriber

      Also I made sure I am running 18.1

    • ECEPSU
      Subscriber

      If I delete the electromagnetics physics type I cannot add another physics type! Something is wrong with the program. I have installed version 18.1 on two Windows 10 machines, one Windows 8.1 Machine, and 1 Windows 7 machine and gotten the same results.

       

      There are may features that are missing that are listed in the help manual. The physics type feature is broken as shown above, and I haven't seen items such as Physics > Settings > Frequency Response anywhere in the actual program. Nor have I seen any visual aids referencing these tools.

       

      The program actually states that it cannot find "GetGeneralPhysicsOptions"!

      Also, the "Unsupported type for creation" error occurs every time I run the electromagnetics module and select one of the options 

    • Vishal Ganore
      Ansys Employee

      Alec, here is the webinar link on relay switch showing how to setup magnetostatics physics under ANSYS AIM. I hope this helps.

      http://www.ansys.com/Resource-Library/webinar/ansys-in-action-calculating-force-in-a-relay

    • ECEPSU
      Subscriber

      Thank you for directing me to that tutorial, it confirmed the where "Physics Options" and "Electromagnetic Conditions" should be. However they are still not available in my installation.

      In the video, Ming imported his geometry and specified the static calculation type. I did the same, as usual, and didn't see "Physics Options" and "Electromagnetic Conditions". He was using 18.0, so I'll try installing 18.0 again and follow his steps exactly (importing geometery is in a slightly different order in 18.1)

    • pgl
      Ansys Employee

      Can you perform a clean installation?  Your current installation might be corrupted or getting confused with some license manger settings from an earlier version that was installed. i.e. Remove ALL versions of the Student product, including the License Manager IF you have previously installed the Release 17.2, or an even earlier version of the the product. This is key. Then download and install R18.1 again, preferably on your Windows 10.0 machine. 

      I still recommend that you use Release 18.1 as it adds further electromagnetics capability compared to 18.0.

       

       

       

    • ECEPSU
      Subscriber

      I just performed a clean install of 18.1 and still no luck.

      In addition to my Windows 10 desktop, I have installed it on my Windows 10 laptop, Windows 8.1 work laptop, and created a new partition on my desktop where I installed it on Windows 7. I still get the same errors on each machine

      I have also made sure to re-download the .zip file several times. I deleted the old directory from 17.2 as well. I've made sure that I have all of the prerequisite programs installed. I've been running the installation as an Administrator as described in the installation directions. 

      The tutorials are for the commercial version, correct? Has anyone tried these tutorials on the Student AIM version?

      Thanks,

      Alec

    • pgl
      Ansys Employee

      HI Alec, 

      You've been extremely diligent in your installation and testing. I'm sorry that you are still running into problems. 

      The tutorials on our academic webpage and YouTube channel are designed for the AIM Student product. But generally, the AIM student product differs from the commercial AIM Pro product only in terms of the numerical problem size & geometry limits. The errors you are sharing don't immediately point to those limits being hit, so something else is wrong here. 

      On my personal R18.0 AIM Student installation I'm able to see and interact with "Physics Options" AND "Electromagnetic Conditions", so it is unusual that you don't see these options in your installation! Here's my screenshot:

      Whereas you see:

       

      I'll forward this over to Ming Yao for his review. 

      Hang in there.

       

       

    • ECEPSU
      Subscriber
      Thank you!
    • mingyao.ding
      Ansys Employee

      Errors like this typically indicates that the project has been corrupted some how. 

      Usually you need to start a new project or reload the project before the corruption.

       

      Does any of the other simulation templates work? 

      When you start a new project. At what point do you get the 1st error?

      You can also try deleting this folder

      C:UsersusernameAppDataRoamingAnsysv181

      ANSYS uses this folder to store local settings so this acts like a reset.

       

      Best regards

       

       

    • rexxar
      Subscriber

      I have same problem too, same error like ECEPSU have. I have try two simuluation, in both i have same error. When i start a new project, import geometry file and when i go to "Physics" then show error.

    • pgl
      Ansys Employee

      Go ahead and try some of the suggestions that mingyao.ding@ansys.com provided above. i.e. "..Errors like this typically indicates that the project has been corrupted some how. ..Usually you need to start a new project or reload the project before the corruption.

      • Do any of the other simulation templates work? 
      • When you start a new project. At what point do you get the 1st error?
      • You can also try deleting this folder
      • C:UsersusernameAppDataRoamingAnsysv181
      • ANSYS uses this folder to store local settings so this acts like a reset.

      Keep us posted. 

    • hollansk
      Subscriber

      I too am having the same challenges developing an electromagnetics simulation. I was hopeful to have students use AIM to visualize fields.

      I set up a simple two magnet geometry. Immediately after importing the geometry, I receive the "Physics Region Warning" and "Selected Physics Type is not valid" message. No further options. I have tried a clean reinstall and all of the tricks above. Any progress on this issue?

      Would it be better to switch to the ANSYS Student instead of AIM? Just concerned about learning curve for students... but working is better than not, I suppose!

    • Windows 8.1 Pro x86
      Subscriber

      I installed new Windows 8.1 Professional x64.

      Installed Ansys 18.1 on it and got the same problem -  it can't run electromagnetic

      Uninstalled Ansys 18.1, restarted my laptop, installed Ansys 18.2 and got the same problem

      Yes my laptop is old 3GB of RAM, Core 2 Duo 2.4 Ghz CPU, Nvidia 9600GTM. But is it really hardware problem? ECEPSU got the problem on 4 different PCs.

      How does one fix it?

       

       

    • alvromcal
      Subscriber

      Hi guys, 

      I'm having the same kind of problems as you, and I am employing a new powerful Workstation (i7, 16 Gb RAM, 1 tb SSD, 2tb HDD, NVIDIA Quadro 2200M...). Has anybody found a solution? 

       

      Bests

    • FixIT
      Subscriber

      Why have not you fix it yet?

    • peteroznewman
      Subscriber

      Yoda?  You should meet Les-O-Lee, you might have a lot in common!

    • pgl
      Ansys Employee

      Hi everyone,

      Sorry that you've all been running into these issues with Electromagnetics in the ANSYS AIM Student product. Part of the difficulty in diagnosing the problem is that it has not been possible to reproduce your specific issues on our local machines. This might point to hardware compatibility issues as being the culprit. I'm really not sure what the issue is, but I am concerned that we now have 4 users reporting similar issues here on our Student Community:

      • ECEPSU
      • rexxar
      • hollansk
      • alvromcal 
      • Windows 8.1 Pro x86 
      • FixIT

      Looking at your IP addresses, this is not an issue relating to a specific countries operating system/language as one of you asked. 

       

      To help our support and development team review and diagnose the issue I've extracted the various replies from this original and several unrelated threads and moved them to new separate posts grouped under the "Electromagnetics" category. You'll most likely complain, but this allow me to point our support and development team to your (and others) specific issues without having them scrolling through extremely long threads. 

      We owe you a response. Stay tuned.  

    • Vishal Ganore
      Ansys Employee

      Hi Guys,

      Sorry for the delay in getting back on this. Our development has sorted out this issue. It will be resolved in upcoming R19.1. The short-term solution is as follows:

      1. I have attached missing folder (Ansoft). Download and extract the folder. 

      2. Copy and paste Ansoft folder under addins. Default path is C:Program FilesANSYS Studentv182Addins

      3. Open AIM and enjoy electromagnetics. 

      Above steps should work for 19.0 as well. Let me know if you face any issues.  

    • mrzac
      Subscriber

      Hi !

      I have recently installed AIM Student 19.0 (Win10 64 bits) for developping Electromagnetic simulations.
      Without the missing folder (Ansoft), I also had the error.

      with the missing file, this error has disappeared but I have another when I lauch the solver :

      Submodel: Failed to launch pm2ansoft.

      Thank you for your help.

    • Vishal Ganore
      Ansys Employee

      I hope you followed the same process as I described. Can you try installing 18.2, copy ansoft folder and see if you get the same error?

    • mrzac
      Subscriber

      Thank you for the response.

      Yes I have followed the procedure but with Ansys AIM 19.0.
      I have to try with 18.2 !

      Edit : No problem with 18.2 version. Thanks

    • FixIT
      Subscriber

      The patch doesn't work for 18.1 and 19.0.

      It works only for 18.2.

    • Vishal Ganore
      Ansys Employee

      Hi, this issue has been fixed under latest R19.1 now. 

Viewing 29 reply threads
  • You must be logged in to reply to this topic.