Photonics

Photonics

Can’t setup the plane wave in lumerical fdtd.

    • vahram.voskerchyan3
      Subscriber

      I set the dimesnions of the plane wave through script but when I ran the simulation, the dimensions of the plane wave change back.

      In the picture is shown after I set it through script but when I ran the simulation, the plane wave becomes wide again

       

      When running the simulation it changes back again and doesn't keep the dimensions I have set up through script. 

      Here is the example script:

       

      switchtolayout;

      redrawoff;

      deleteall;

       

      addfdtd;

      set('dimension',1); 

      set('x max',50e-6);

      set('x min',0e-6);

      set('y',0);

      set('y min',-2e-6);

      set('y max',2e-6);

      set('z',0.0e-6);

       

      set('mesh accuracy',8);

      set("mesh refinement","conformal variant 0");

      set("mesh type","uniform");

      set("dx",20e-6);

      set("dy",20e-6);

       

      addplane;

      set("name","plane wave");

      set("injection axis","y");

      set("direction","backward");

      set('x',30e-6);

      set('y', 1e-6);

      set('x span',20e-6);

      set('z span',2-6);

      set('z',0.0e-6);

       

       

       

    • Guilin Sun
      Ansys Employee

      There are several issues in your settings:
      1: in principle, plane wave only works with periodic BCs so the structure has to be periodic. To prevent users using smaller plane wave dimension than the perioid, the software AUTOMATICALLY extends its dimension to be outside of the boundary conditions. This is why it changes.

      2: You can use TFSF source as this is a local plane wave. However, the monitor should not touch TFSF as its boundary condition is used for other purpose and the data on the boundary is not physical.

      3: If the nano strucutre is finite, the substrate should be infinite in the plane perpendicualr to propagation. Please extend the substrate and all other non-finite size layers  to the out side of the PML.

       

Viewing 1 reply thread
  • You must be logged in to reply to this topic.