Fluids

Fluids

CFD-post application failing to connect

    • Nabaraj
      Subscriber

       Hi,

      I am using Ansys Fluent 18.1 Student version. It was running all good earlier. But now when I try to open "Results" for post-processing in workbench , the following error message pops up. Anybody have idea what is wrong and hot to fix it?

      System.ApplicationException: Application failed to connect.

         at Ansys.CFX.Foundation.App.CUEApplicationProxy.Start(Boolean waitForCommands)

         at Ansys.CFX.CFDPost.App.CFDPostProxy.LoadApplication()

         at Ansys.CFX.Foundation.Data.CUESourceDataObject.Edit(IFullContext context, Boolean interactive)

         at Ansys.Core.Commands.Concurrency.CommandWorkUnit.executeInContext(CommandContext subContext, IExecutionEngineCallback tracer)

         at Ansys.Core.Commands.Concurrency.BaseWorkUnit.doExecute(IExecutionEngineCallback executionEngine, CommandContext subContext)

         at Ansys.Core.Commands.Concurrency.BaseWorkUnit.Execute(IExecutionEngineCallback executionEngine, Boolean dontCatchExceptions)

      --- Ansys.Core.Commands.CommandFailedException: Application failed to connect.

      CommandName: CFX.EditResultsAnalysis(Container="Results")

         at Ansys.Core.Commands.CommandAsyncResult.RethrowFailureException(Exception e)

         at Ansys.Core.Commands.CommandAsyncResult.Wait(Int32 milliSecondsTimeout, Boolean exitContext)

         at Ansys.CFX.CFDPost.Commands.EditResultsAnalysisCommand.InvokeAndWait(IProtectedContext context, DataContainerReference Container, Boolean Interactive)

         at Ansys.CFX.CFDPost.Commands.EditResultsAnalysisGui.Invoke(GuiOperationContext context)

         at Ansys.UI.GuiOperationContext.Invoke(GuiOperationMetaData operationData)

         at Ansys.UI.UIManager.InvokeOperationCore(String pseudoname, OperationDelegate callback, Boolean allowOSMessages, Boolean coreTransaction)

      Thanks in advance.

    • Vishal Ganore
      Ansys Employee

      Could you please try clearing data from Results component?

    • Nabaraj
      Subscriber

      Hi vganore,

      Thanks for the quick reply.

      Clearing data from Results component did not help either.

      Workbench also pops up the same error on refreshing the "Results" component.

      Thanks.

    • Vishal Ganore
      Ansys Employee

      Take another result component in workbench from component system and connect your solution cell with new results component. See if that helps. 

      If same problem persists then try opening CFX in a standalone mode through windows start menu. See if it gives same error. Might be a license issue.

    • Nabaraj
      Subscriber

      Thanks vganore for the suggestion.

      New linked results had similar error. CFX standalone mode had error too. May be the license issue like you suggested.

      I had another fresh installation of Ansys 18.2 and all is good now.

      Many thanks for your response.

    • tjzhgs
      Subscriber

      I have the same issue when I use 19.2 student version. Could you please tell me how you figure out your problem?  Your suggestion is useful to me. Thank you!

       

    • shazimy
      Subscriber

      Hello,

       

      Have you found any solution for this issue?

       

      Shahab

    • Rob
      Ansys Employee

      You're better off logging a new question in Installation, that way we can check if it's the same problem. 

    • anandhu_suresh
      Subscriber
      iam experiencing same issue with 2020R2 Student version.I tried re-installing multiple times still issue persisit.
      When clicking on results its showing application failed to connect.
      Please help!!
    • sp_ef
      Subscriber
      I am experiencing the same issue! It would be much appreciated if anyone could help with the issue!
      Spyros
    • Rob
      Ansys Employee
      I'll refer you to my previous comment, and lock this thread.
Viewing 10 reply threads
  • You must be logged in to reply to this topic.