Ansys Products

Ansys Products

CFX Cooling to below Inlet Temperature

    • Lisa Hildebrand
      Subscriber

      Hi all,

       

      I'm trying to run an electronics cooling simulation in ANSYS CFX.  I'm using a very similar setup to the "ANSYS CFX Tutorials - Section 14 (Conjugate Heat Transfer in a Heating Coil)" tutorial.  I can take screenshots and provide additional information if necessary, but I'm not sure what information would be helpful at the moment. 

       

      My inlet temperature is set to a constant 21 degrees C, and my inlet velocity is set to 3 m/s.  My outlet is set to an "opening" with a static temperature set to "areaAve(T)@REGION:outlet" (with "outlet" being the named selection name for the outlet geometry).  I have a series of blocks with a constant heat flux.  These blocks are in one solid domain, and they're connected by very thin sheet metal tabs (in a different solid domain) to more blocks that fluid is flowing over.  The blocks and tabs are currently aluminum, and the fluid is air (the default "air" material available in CFX). 

       

      For some reason, parts of my solid domain are showing up as being a few degrees below the inlet temperature.  (Particularly, my very thin tabs are ~19 degrees, which is below my inlet 21-degree temperature).  I was wondering if this is a common problem people have?  My mesh is very coarse right now and not good for accurate fluid flow; this was just my first attempt at setting up a full-scale simulation.  Potential probems that I can think of are:

      -bad mesh (would this cause the temperature to go below the inlet temperature?)

      -too many solid domains that aren't connected properly (I have a solid domain defined for each area that I want to be able to look at individually in the CFX-Post - is there a better way to do this that allows all the solids to stay in the same domain?)

      -Some setting I'm not aware of that creates a separate ambient temperature or causes parts to be below the inlet temperature in some other way.  (Maybe the default "air" material has a temperature associated with it?)

       

      If anyone has any insight, please let me know.  I can attach files (although this file is relatively large) or take screenshots of anything you need. 

    • rfblumen
      Ansys Employee

      Assuming that the heat flux value entered is positive, the reason why there may be low temperature values in the model relative to the inlet temperature may be due to the energy equation not being converged.  How is the convergence in terms of the RMS residulas for mass, momentum and energy?  What is the percent imbalance for these equations (found near the end of the CFX .out file under Normalised Imbalance Summary)?

      If running with Auto Timescale, sometimed the resulting solid time step is too high.  Check in the out file in the convergence history for the value used for the solid time step.  Change the time step form Auto Timescale to Physical Timescale.  Set the solid timescale to a lower value.

      If convergence is reasonable and changing the solid timestep doesn't help, it may be related to skewed or poor mesh.  You could try setting the expert parameter "cht diffusion scheme = 6" (default value is 5). 

      If this doesn't work, and the low temperature is only on the GGI, try setting the expert parameter "ggi ap relaxation=0.3".  Note that this will need to be set in the Expert Parameter section by a copy/paste of this command through Edit-in-Command Editor since this is a hidden expert parameter and not exposed in the GUI.  You'll first need to have at least one expert parameter alread set for the Expert Parameter section to be persistent.

    • Lisa Hildebrand
      Subscriber

      Thank you very much for your reply!

       

      The Normalised Imbalance summary table is here:

      Normalised Imbalance Summary                   |
       +--------------------------------------------------------------------+
       |       Equation       |      Maximum Flow     |     Imbalance (%)   |
       +--------------------------------------------------------------------+
       | U-Mom-Default Domain |       2.1573E+00      |       -0.0044       |
       | V-Mom-Default Domain |       2.1573E+00      |       -0.0057       |
       | W-Mom-Default Domain |       2.1573E+00      |        0.0011       |
       | P-Mass-Default Domai |       9.3375E-03      |        0.0101       |
       +----------------------+-----------------------+---------------------+
       | H-Energy-Default Dom |       1.8127E+07      |        0.0000       |
       | T-Energy-lowerbusbar |       1.8127E+07      |        0.0000       |
       | T-Energy-solidOther  |       1.8127E+07      |        0.0000       |
       | T-Energy-tabs        |       1.8127E+07      |       -0.0000       |
       | T-Energy-upperBusbar |       1.8127E+07      |        0.0000       |
       | T-Energy-solid       |       1.8127E+07      |        0.0000       |
       +----------------------+-----------------------+---------------------+

       

      It seems like the imbalance percent is relatiely low, but I'm not sure what's normal. 

       

      I was using the auto timescale, and my mesh was very poor-quality, so I'll look into those next.  Thank you so much!

Viewing 2 reply threads
  • You must be logged in to reply to this topic.