Topics related to Lumerical and more

Compiling the plugin material on Windows: Memory/CPU allocation issues

    • George Kountouris

      Hi everyone,

      I have successfully compiled my code on Linux, and it runs fine.

      On Windows, I have used the preprocessor definitions suggested here, on Visual studio 2022

      While the material is recognized, it only sometimes runs, and often after significant delays, getting stuck at the setting up stage usually.  I have realized that when running the simulation on a single thread (single core), the simulation gets set up and running normally.  Looking at the task manager to compare between successful and unsuccessful runs, it seems that CPU/memory allocation is the problem:  the program fails to find/allocate resources for the simulation to run (sometimes; or takes too long to do so).

      I have also tried compiling the dll with Visual Studio 2013, as suggested in the link, but the material is not recognized, even when manually changing the preprocessor definitions like when I tried it in the newer version.

      Any ideas?





    • Guilin Sun
      Ansys Employee

      Unfortunately it is difficult to diagnose when 3rd party software or tools are involved. For example, minor difference of the versions can lead to some issues. and the plugin material is an advanced feature, very limited support can be provided.


Viewing 1 reply thread
  • You must be logged in to reply to this topic.