Fluids

Fluids

Creating a new particle mixture template by editing the material database file in fluent

    • Wufl123
      Subscriber

      Hello everyone,

      I want to simulate a multi component species evaporation. I am using the DPM model and have created a surface injection for injection of the propellant.

      The propellant consists of 3 species in liquid state that will be injected and will get evaporated. I have selected multicomponent as the particle type. Now I need to define this particle mixture template by adding my 3 species- water, methanol and ADN in liquid state. In the material database file, probdb, intially the particle mixture template only consists of h2o. I added ch3oh in the particle mixture template by editing the file. ADN in liquid state (nh4n(no2)2) wasn't defined in the material database by adding it to the database by defining properties that I could find. I couldn't find the critical properties for it, so I didnt add them.

    • Rob
      Ansys Employee
      The best route is to edit materials and create the mixture in Fluent and then save it as a user material. If you're editing the files in the Fluent install I have no idea what will happen.
    • Wufl123
      Subscriber
      Thanks Rob for answering, are you saying create a new material with properties of the mixture?.
      Because when I try to create a new particle material mixture, only h2o and ch3oh are listed as the available species. But when I click on the fluent database tab in 'create/edit material tab' and select particle type as the material type, I can see the particle mixture template listed there. When I click on that I can see all three species defined by me in the 'probdb' file.
      My question is why can't I see nh4n(no2)2 as an available species when I click on the edit button next to the mixture species option but I can see see nh4n(no2)2 defined in the particle mixture template in fluent database.
      Any help will be appreciated.
    • Rob
      Ansys Employee
      Create the extra species in Fluent, then create the droplet-mixture. Then save it as a user material/database.
      Fluent now stores mixture materials separately to the species materials, it's for when some materials are used in two mixtures. This can lead to confusion: you want the mixture material and it's contents.
    • DrAmine
      Ansys Employee
      Create first droplet material which can be added to particle mixture material. Di all that by editing available materials in Fluent then saving them into the case.
    • Wufl123
      Subscriber
      Thanks for answering DrAmine and Rob, so when I tried to create a new droplet particle, I get the following error-
      Error : Set_Material_Property : wta(real)
      MPI Application rank 0 exited before MPI_Finalize() with status 1 Error encountered in critical code section.
      And fluent crashes just seconds after. How to resolve this error?
    • DrAmine
      Ansys Employee
      Start from Mesh, Enable Species Model, Enable DPM by just creating a default droplet. Now add your droplet materials. After that go back to injection switch to multicomponent, stick to default, now go back to material and edit that mixture by adding the droplet materials you require.
    • Wufl123
      Subscriber

      Hi DrAmine, I followed your suggestion-
      1) Started from mesh
      2) Enabled species model and imported the appropriate chemkin mechanism
      3) Enabled DPM and selected particle type as droplet and kept everything as default
      4)Created ADN liquid material by selecting a new droplet particle
      5) Went back to the injection (I have created a surface injection) and selected multicomponent
      But when I do this I get the following error message - Error: CAR: invalid argument [1]: wrong type [not a pair]Error Object: #f
      And though the particle mixture comes into the material tab but there's no plus sign next to it.
      Am I doing anything wrong? I am fairly new to fluent and any suggestions will be welcomed. Eager to hear from you.
    • Rob
      Ansys Employee
      Try:
      Step 2) turn on species.
      Step 3) turn on multicomponent (remember to set DPM to interacts with continuous phase)
      Step 3a) Import the ChemKin model
Viewing 8 reply threads
  • You must be logged in to reply to this topic.