Fluids

Fluids

Customizing contour color map using TUI?

    • m.shafiee1374
      Subscriber

      Hello,

      I simulated a case of fluid flow on an HPC cluster using Ansys Fluent 19.2 in batch mode. The simulation worked fine and since I did not have enough RAM to read the data file for post processing, I'm trying to save images of my contours remotely using TUI commands. So I use this shell command to run fluent to have graphics enabled:

      fluent 3ddp -gu -t16 -mpi=openmpi -i &Name.jou >& out_$Name.log 

      then I use these TUI commands to define a contour and then save an image of it:

      ;---Display settings

      /display/views/read-views "Views" 

      /display/set/contours/auto-range? yes 

      /display/set/contours/clip-to-range? no 

      /display/set/contours/filled-contours? yes 

      /display/set/contours/global-range? no 

      /display/set/contours/n-contour 30 

      /display/set/contours/node-values? yes 

      /display/set/lights/headlight-on? no 

      /display/set/lights/lights-on? no 

      /display/set/picture/color-mode/color 

      /display/set/picture/driver/png 

      /display/set/picture/x-resolution 960 

      /display/set/picture/y-resolution 720

      ;---Defining contour surfaces

      /surface/plane z0plane 0 0 0 0 1 0 1 0 0

      ;---Saving contours

      /display/set/contours/surfaces z0plane () 

      /display/contour velocity-magnitude 3 8

      /display/views/restore-view xplus-view 

      /display/save-picture "z0plane_V.png"


      And all of them work fine except that the saved contour does not have any labels on its colormap(!!!), no numbers.

      I tried to use /display/set/color-map menu, but it seems like that only changes the colors of the contours.

      How to fix this?

      Thanks❤️

    • Rob
      Ansys Employee
      Please can you post one of the images? I wonder if you've got white text on a white background.
    • m.shafiee1374
      Subscriber
      Sure, but I dont think thats the case:


    • Rob
      Ansys Employee
      can you add
      /preferences/appearance/gfc 255 0 0
      at the beginning of the above and see what you get? We moved the foreground/background options into Preferences and I wonder if that's causing a problem here. I don't have R19.2 installed so can't check here.
    • DrAmine
      Ansys Employee
      Can you move to a newer version and also try using Contour Objects.
    • m.shafiee1374
      Subscriber
      Hello and thanks for your responses Using contour objects worked.
    • DrAmine
      Ansys Employee
      Super! Welcome!
Viewing 6 reply threads
  • You must be logged in to reply to this topic.