Photonics

Photonics

“CVCS” or “none” for the taper waveguide coupler

    • iqnlo
      Subscriber

      Hi there

      I am doing mode convergence test for my own design of edge coupler. But I found that the mode didn't converged. When I was using CVCS at the taper structure region and the energy conservation setting is "make passive"

      I'm using the codes from this page: Convergence testing process for EME simulations – Lumerical Support

      First of all, I applied this script on your official edge coupler: Edge coupler – Lumerical Support

    • iqnlo
      Subscriber
      By the way, I recently noticed that the result from the CVCS one is relatively converged except for some noise.
      So shall I take the 60 modes as where the modes start to converge? The noise are because there are too many modes as said in the tutorial. So maybe I can ignore the noise and view this as a good result?
      Thanks! I'm looking forward to your comment.
      Best wishes
    • Taylor Robertson
      Ansys Employee
      This perturbation to the S matrix arises due to energy conservation and CVCS being used. I would direct you this video for an explanation of what is going on here.
      https://support.lumerical.com/hc/en-us/articles/360045466833-Convergence-Testing-Too-Many-Modes
      You may need to increase the number of cells to get the convergence to behave better. Although convergence becomes more difficult using CVCS and energy conservation would ideally make the results more accurate. Make passive may be the best option for this type of situation. To understand where the problem is coming from you may want follow the procedure outlined in the link below.
      https://support.lumerical.com/hc/en-us/articles/4412892724243-EME-Convergence-Testing-An-Intuitive-Approach
      Best

Viewing 2 reply threads
  • You must be logged in to reply to this topic.