Electronics

Electronics

Electronic Desktop HFSS does too many passes (until the solver is out of memory)

    • DmitriiKruglov
      Subscriber

      Hello,


      For some reason HFSS does too many passes, beyond what I've been setting up in the solutions setup. It carries out pass after pass until there are too many nodes for the solver and it returns "Solver out of memory" error. Is there something I am doing wrong?


      Thank you,


      Dmitrii

    • Karthik R
      Administrator

      Hello,


      I moved your question to the 'Electromagnetics' thread to ensure it gets the traction it deserves.


      Thank you.


      Best Regards,


      Karthik

    • asamaiyar
      Subscriber

      Hi Dimitri,


      This may happen due to following reasons:


      1) You have a high resonant structure at your meshing frequency (try to mesh at slightly higher frequency and run discrete frequency sweep).


      2) You S-Parameter (or delta energy in some cases) convergence criteria is very low. Default is 0.02. I sometimes go for 0.01 when I really want to push the mesh.


      3) Try mixed order basis function instead of first order.


      Also, what is your definition of "too many passes". I usually set my default max to 20. (Sometime 40 based on complexity of model).


      How much RAM do you have? Sometimes the computer in not powerful enough (in terms of RAM) to solve the level of complexity of the problem. So you might have to try this on a bigger machine (more RAM).


      Hope this helps.


      Aman

    • DmitriiKruglov
      Subscriber

      Hi Aman,


      Thank you for your reply! I am sorry for my late response, I was sick for couple of days.


      "Too many passes" means that I set this number to be, let's say, 6, but the software keeps refining the mesh until it drives itself out of memory. We have 32 gb ram, so I was hoping it is not the problem.


      1) This is very possible, I am looking at it right now. I indeed was looking at the field distribution around the resonator at the resonant frequency.


      2) I set the S-parameter to be 0.1, which is rather big than small.


      3) Will do!


      I will mark the thread "solved" if the frequency de-tuning or mixed order basis functions will help. Thanks!


      Dmitrii

    • DmitriiKruglov
      Subscriber

      De-tuning the frequency and setting the mixed-order functions solved the problem!

    • asamaiyar
      Subscriber

      I must also mention that it is highly recommended that you mesh your model at resonant frequency for most accurate results. De-tuning is just a quick workaround to roughly check if you are getting what you kind of expect.

    • asimghalib
      Subscriber

      Hi everyone.


      Currently, I am running a CMA analysis (HFSS) on a 32 GB RAM machine. Still, I am getting the "Out of memory" message. I made the adaptive passes to 1 but still, I am getting this message. any idea how to fix it?


      thanks in advance 

    • asamaiyar
      Subscriber

      I have never performed CMA on HFSS. But if you are performing this analysis using eigenmode solver, then one way to same time and memory is to request less number of modes. Please start a new discussion thread if you want the opinion from a wider audience.


      --AS

Viewing 7 reply threads
  • You must be logged in to reply to this topic.