Fluids

Fluids

Error: 6DOF object must have positive mass

    • Lindsay
      Subscriber

      Hello,


       


      I have been trying to run a 2D simulation in fluent with 2  vertical axis wind turbines. The purpose is to see how the resulting flow from the front VAWT (A) impacts the trailing VAWT (B). I can get simulations with one to run correctly, but when I add a second, I keep getting :


      Error: 6DOF object must have positive mass.


      Error Object: #f


      For my 6DOF setup, I have two  specified properties, one for vawt A, and one for vawt B, both with appropriate center of rotations specified. I have included the  moments of inertia for both - and I have also experimented with changing those to different numbers just to see if the error would go away - but it hasn't. 


      Does anyone know what I am missing or doing wrong to get this error?


       


      Thank you!!!


       


       


       

    • klu
      Ansys Employee

      Hi, 


      Can you please post a couple of screenshots of your model, 6DOF properties, Dynamic Mesh settings, etc. so that others get a better idea about the setup?

    • Lindsay
      Subscriber

      Yeah for sure! Let me know if you need any others. Thank you!!!!!!!!!


    • klu
      Ansys Employee

      Hi,


      Thanks for posting the screenshots of 6DOF properties. I did not see any problem with them. In the meantime, could you please also add a few screenshots for dynamic zones, especially the rigid bodies?


      Sometimes bad initial conditions or mesh quality could also lead to failures of dynamic mesh (DM). Can you also please try to get a steady solution by turning off DM and then turn on DM? If the error does not occur again, you might need to give better initial conditions or improve the mesh quality. Let me know how it works.

    • Lindsay
      Subscriber

      So, after doing that, it actually runs through calculations - but the turbines don't rotate. I tried disabling the dynamic motion of the trailing VAWT, to see if I could just get the front one so rotate, but it doesn't. I took one of the single VAWT projects that worked, added a second, and removed that area from the outer domain. Is there an additional setting that needs to be changed since there are 2 rotating areas? Sorry, I have just been using ANSYS since late summer, so I am unfamiliar with a lot of the possibilities of the program. Here is a pic showing that they are not rotating, but being treated like two stationary cylinders.


       


      Thank you!!!!! 


    • klu
      Ansys Employee

      Can you show me the panel of Dynamic Mesh Zones in your model? Also what variable is plotted in the picture you sent? Is it velocity magnitude?


      You may refer to the below items for further investigations.


      1. Please check the materials for both rotating circular zones. Make sure they are fluid zones and the material is air. (Assume you plotted the velocity magnitude.)


      2. Non-conformal interfaces should be used between the rotating and stationary zones. To confirm if the interfaces work properly, you may simply activate Mesh Motion on both rotating zones using a constant rotating speed. Then click on Preview Mesh Motion to check the mesh rotation.


      3. Apply the 6dof properties to the turbine blades (they are all walls in this case) and set them as the Rigid Body type.


      4. Apply the 6dof properties to two rotating zones respectively. Also set them as the Rigid Body type but activate the Passive option in the DM Zones panel so that forces and torques will not be applied.


      5.The transient solver must be used after turned on Dynamic Mesh.


      Please let us know how it works.


       

    • Lindsay
      Subscriber

      All right, so 1, 3, 4, and 5 have been confirmed. #2, I have tried, but couldn't - and honestly have never gotten the preview mesh motion to work - even though the turbines would rotate calculating - so I never really leaned on that at all. I attached the dynamic mesh zones pics. I have been trying to run calculations again, and am getting the original error, and can't get it to go away this time. 


      Error: 6DOF object must have positive mass.


       


      Error Object: #f


      oh! and yes, the previous pic is of velocity contour. 


      Any other suggestions?


       


      Thank you!!!!!


       



       


       

    • klu
      Ansys Employee

      To create non-conformal interfaces, please go back to geometry editor and unshare topology between these three zones (I guess avawtdomain, bvawtdomain and outerdomain). Then re-generate the mesh and import it to Fluent again. You will see Mesh Interfaces in the Fluent tree panel. As mentioned in previous replies, next please activate Mesh Motion for the rotating zones avawtdomain and bvawtdomain and input rotation origins, axis and speed (double click the cell zone so you can open the panel). Now turn off the Dynamic Mesh and preview mesh motion should work. 


      After previewing the mesh motions, deactivate Mesh Motion for both rotating zones and turn on Dynamic Mesh again. Remove the outerdomain from DM zones panel. Then I think DM should work properly. 


      However I would suggest get a steady solution before turning on Dynamic Mesh. First it can check whether there is something else wrong in the model settings (for example zero velocity in the two rotating zones are suspicious). Second it can provide good initial conditions for DM simulations. Please try the above out and let us know. 

Viewing 7 reply threads
  • You must be logged in to reply to this topic.