Fluids

Fluids

Error at Node 0: update_absorption_coefficient: CO2 not defined.

    • ozankekul
      Subscriber

      Hello , 


      I'm trying to model ammonia combustion in fluent. I use DO radiation model , but since my reaction does not produce CO2 , i get this error after initialization. And fluent does not allow to run calculation. How can i solve this problem .


       


      Thanks. 

    • Rob
      Ansys Employee

      Check the pdf setup: if CO2 is in the materials list just put in a value for absorption coefficient. Or remove it from the list. 

    • ozankekul
      Subscriber

      i have checked pdf setup. there is not any co2 in the material list . indeed , main problem is that my reaction is nh3+o2=n2+h2o and there is no co2. i think, i should use radiation model for my case but no co2 in the products. 


       

    • Rob
      Ansys Employee

      Did you use WSGGM model in DO Model?  

    • ozankekul
      Subscriber

      yes , i use wsggm domain based model as absorption coefficient. i added some picture. Please check it.



    • Rob
      Ansys Employee

      Have a look in the Fluent User's Guide under the section on Absorption Coefficient ( 8.8.1.2 in the 2019R2 DOC ) and let us know what you find about the WSGGM option. 

    • ozankekul
      Subscriber

      Can you give me a link for Fluent User's Guide under the section on Absorption Coefficient ( 8.8.1.2 in the 2019R2 DOC )

    • Rob
      Ansys Employee

      It'll not work as you'd need Portal access, click on "Help" and have a look. 

Viewing 7 reply threads
  • You must be logged in to reply to this topic.