Optical

Optical

Error for metalens S params for a certain combination of pillars and substrate

Tagged: 

    • U Abinash Patro
      Subscriber

      I downloaded the latest metalens zip file from the website. In the unit cell simulation file, I changed the material and structural properties like height ,radius. I also changed wavelength and period . When I try to see how the phase changes, it shows S variable is empty.  When I run the analysis of S params, I get this output:-

       

      Any comments to resolve this issue?

    • Guilin Sun
      Ansys Employee

      Did you use broadband source or single wavelength like the example online?
      what is the value for "target_grating_order_out"? by default it is 0th order.

      You can use question mark to get the values of the variables:

      ? target_grating_order_out;

      ? n_array;

      and check why it shows the error.

       

       

      • U Abinash Patro
        Subscriber

        In the S params, the target grating order is defined as 0.

    • U Abinash Patro
      Subscriber

      I used single wavelength source. Also I imported the material data from a file. I ran the above commands and got this:

      ? target_grating_order_out;
      Error: prompt line 1: target_grating_order_out is not a valid function or variable name
      ? n_array;
      Error: prompt line 1: n_array is not a valid function or variable name

    • Guilin Sun
      Ansys Employee

      Then you will need to use ? to check all the quantities before the error line and find out why those parameters have no value.

       

      • U Abinash Patro
        Subscriber
      • U Abinash Patro
        Subscriber

        hi I am stil unable to resolve this. The error doesnt show for the parameters of unit cell original file. I dont know why it only shows for my parameters.Here are the parameters I used for which I got an error:

        wavelength: 390 nm, pilllar user defined dielectric index: 2.365,substrate: Si02 glass,period:250 nm, radius sweep: 40-85 nm, height sweep:300-500nm.

        But when my period was increased to 300nm, there wasnt any error. Are there any conditions for which we have to set our period or other parameters to have a errorless simulation?

    • Guilin Sun
      Ansys Employee

      Unfortunately I could not help more, as I cannot see or edit your file. Please follow my previous suggesion to open the analysis group, in its "ananlysis" script, check every variable using question mark. Maybe your simulation file failed?

      We only give general suggestions since we are not allowed to download or open customer files from the forum. If you have premium support previlege please send us a support email with the problematic file.

Viewing 4 reply threads
  • You must be logged in to reply to this topic.