General Mechanical

General Mechanical

Error in ACP

    • MatteoCouet
      Subscriber

      Hello, 


      I modelled a small composite geometry with ACP in ANSYS Workbench 2020R1. I completed everything until the model data, but then when I want to open the setup part in ACP, Workbench shows an error : At least one exception occurred during the refresh that made it impossible for ACP to complete the process. 


      And the details : 


      System.ApplicationException: At least one exception occurred during the refresh that made it impossible for ACP to complete the process.


         à ACP.Commands.RefreshSetupCommand.ExecuteCommand(IFullContext context)


         à Ansys.Addins.Infrastructure.CommandUtilities.CommandHelper.Execute(IFullContext context)


         à Ansys.Core.Commands.Concurrency.CommandWorkUnit.executeInContext(CommandContext subContext, IExecutionEngineCallback tracer)


         à Ansys.Core.Commands.Concurrency.BaseWorkUnit.doExecute(IExecutionEngineCallback executionEngine, CommandContext subContext)


         à Ansys.Core.Commands.Concurrency.BaseWorkUnit.Execute(IExecutionEngineCallback executionEngine, Boolean dontCatchExceptions)


      --- Ansys.Core.Commands.CommandFailedException: At least one exception occurred during the refresh that made it impossible for ACP to complete the process.


      CommandName: ACP.RefreshSetup(Container="Setup", KeepACPOpen=True, BatchMode=False)


         à Ansys.Core.Commands.CommandAsyncResult.RethrowFailureException(Exception e)


         à Ansys.Core.Commands.CommandAsyncResult.Wait(Int32 milliSecondsTimeout, Boolean exitContext)


         à ACP.Commands.RefreshSetupCommand.InvokeAndWait(IProtectedContext context, DataContainerReference Container, Boolean KeepACPOpen, Boolean BatchMode)


         à ACP.Gui.EditSetup.Invoke(GuiOperationContext context)


         à Ansys.UI.GuiOperationContext.Invoke(GuiOperationMetaData operationData)


         à Ansys.UI.UIManager.InvokeOperationCore(String pseudoname, OperationDelegate callback, Boolean allowOSMessages, Boolean coreTransaction, Boolean deferredRefreshOnly)


      Does anyone had this problem before or knows how to deal with it please?

    • cdn1
      Subscriber
      Hello matteo,nI got the same issue did you solve it?n
    • April Wang
      Ansys Employee
      Hi,nnPlease make sure there's no question mark on the module before setup. Everything should be with a green check mark except for the Setup. The geometry should be a surface.nApriln
    • cdn1
      Subscriber
      Hello april,nEverything is green check and I use a 2D file, see picture below:nHere's the detailled issue on my side:nnn
    • cdn1
      Subscriber
      I tried to import the geometry into design modeler and then link it to my ACP, but it's still not working:nn
    • cdn1
      Subscriber
      Ok, I solved my issue by changing the location of all my temporary files in a new folder I created C:\Ansysdata. I modified it in workbench under Tools/options.nnThanks,n
    • GimliBimli
      Subscriber
      Hey, same issue here. Geometry is a surface, everything except Setup is green checkmarked, location of all my temp. files are in a new folder. Its still not working and i get still the same issue. ACP opens, but looks strange. Any ideas? nn
Viewing 6 reply threads
  • You must be logged in to reply to this topic.