Fluids

Fluids

Error in FSI

    • Pulak Ray
      Subscriber

      Dear all,
      Please see the below messages. These are errors coming out while trying a FSI simulation of flow through a flexible pipe.


      1. Update failed for the Solution component in System Coupling.  The coupled update for system Fluid Flow (Fluent) threw an exception. Update Solution Failed

      2. (DP 0) Poor intersection was identified between the source and target. This error check is triggered when the mapping fraction for both source and target are below the threshold set by MappingControl/PoorIntersectionThreshold (currently 0.5). Please review the mapping details written to the folder 'Results_PoorIntersection' in Ensight for potential setup issues. It may also be helpful to (a) increase the Absolute or Relative Gap Tolerance (if the interfaces are separated) or (b) change Face Alignment (if the interface mesh normals are inward-directed or if there are shell elements). You can deactivate this check with MappingControl/StopIfPoorIntersection. Please do not save the project if you would like to recover to the last saved state.


      Kindly help me with this.
      Thanks in advance.

      #FSI #Fluent #Ansys #error

    • Rahul Mule
      Ansys Employee

      Hi Pulak,

      1. Please check fluent transcript file (.trn) to check what is causing issue.
      2. It seems like mapping is not happening properly. Please review 'mesh statistics' and 'mapping summary' in system coupling log file (scLog.scl).

      Please refer the best practices to setup system coupling project. Best Practices for System Coupling (ansys.com)

      Hope this helps!

    • Alexandre Carvalho
      Subscriber

      Hello Pulak,

      Did you manage to find a solution for this problem? I have the same issue when trying to run a FSI simulation, even after defining connections in SpaceClaim and creating a homogeneous mesh transition between the source/target. 

      Thanks in advance.

    • Rahul Mule
      Ansys Employee

      Hi,

      *PoorIntersectionThreshold (setting) defines the threshold at which the system coupling stops if the intersection between the coupling interfaces is low. In that case, improve the mapping by adjusting the interfaces or if you wants to continue with that disable intersection check with setting *StopIfPoorIntersection (setting).

      Please refer MappingControl (singleton) (ansys.com) for more information.

    • Alexandre Carvalho
      Subscriber

      I've kept the coupled surfaces in fluent defined as walls (default), should they be defines as interfaces instead? I thought the dynamic mesh zone set to system coupling was enough to couple the simulation correctly. I have also tried to keep a conformal mesh.

      Thank you.

    • Rahul Mule
      Ansys Employee

      Hi ,

      I recommend going over this tutorial in the Ansys documentation that shows a 2-way FSI simulation with Fluent and Mechanical to understand the setup of FSI cases. https://ansyshelp.ansys.com/account/secured?returnurl=/Views/Secured/corp/v221/en/sysc_tut/sysc_tut_reedvalve_fluent.html

    • Alexandre Carvalho
      Subscriber

      Hello, 

      After further investigation, I saw that Mapped Area [%] for both source and target are at 0, even after defining the Fluid-Solid Interface in Mechanical and Dynamic Mesh in Fluent. Are there any other steps to creating the coupling other than defining those surfaces? 

Viewing 6 reply threads
  • You must be logged in to reply to this topic.