Ansys Products

Ansys Products

Error on fluent in Ubuntu 20.04 LTS

    • mehdi Abbas
      Subscriber

      I am getting this error after I try to open fluent on ubuntu

      "Host spawning Node 0 on machine"

    • George Karnos
      Ansys Employee

      This is not an error. this is a message stating that the program is launching on the machine.
      If it does not proceed, first thing I would look at is the prerequisites.
      Make sure ALL are installed.
      https://ansyshelp.ansys.com/account/secured?returnurl=/Views/Secured/corp/v222/en/installation/unix_platform_libraries.html
      As well as:
      https://ansyshelp.ansys.com/account/secured?returnurl=/Views/Secured/corp/v222/en/installation/unix_platform_add_det.html

      Is there more information in the console window? right-click in console window and then choose
      select all. once highlighted, right-click again and choose copy. Then paste the info here.
      EXAMPLE:

       
                    Welcome to ANSYS Fluent 2022 R2
       
                    Copyright 1987-2022 ANSYS, Inc. All Rights Reserved.
                    Unauthorized use, distribution or duplication is prohibited.
                    This product is subject to U.S. laws governing export and re-export.
                    For full Legal Notice, see documentation.
       
      Build Time: May 27 2022 08:52:29 EDT  Build Id: 10212  
       
      Connected License Server List: 1055@SERVER1
      Host spawning Node 0 on machine "SERVER1" (win64).
       
      -------------------------------------------------------------------------------
      ID    Hostname  Core  O.S.         PID    Vendor                         
      -------------------------------------------------------------------------------
      n3    SERVER1   4/24  Windows-x64  13020  Intel(R) Xeon(R) Gold 6136     
      n2    SERVER1   3/24  Windows-x64  30512  Intel(R) Xeon(R) Gold 6136     
      n1    SERVER1   2/24  Windows-x64  23876  Intel(R) Xeon(R) Gold 6136     
      n0*   SERVER1   1/24  Windows-x64  14568  Intel(R) Xeon(R) Gold 6136     
      host  SERVER1         Windows-x64  588    Intel(R) Xeon(R) Gold 6136     
       
      MPI Option Selected: intel
      Selected system interconnect: default
      -------------------------------------------------------------------------------
       
      Cleanup script file is C:\Users\user1\cleanup-fluent-SERVER1-588.bat
       
      Loading "C:\Users\user1/.fluent"
      /file/read-macros "C:/Program Files/ANSYS Inc/v212/Rocky/fluent/udfs/rocky_fluent_coupling.scm"Loading "C:/Program Files/ANSYS Inc/v212/Rocky/fluent/udfs/rocky_fluent_coupling.scm"
       
      ...Rocky-Fluent Coupling Module is not available for the current Fluent release version!
      Done.
      Done.




    • Mangesh Bhide
      Ansys Employee

      Hello
      try these settings in Fluent launcher
      in fluent Launcher click on more options >> then go to parallel settings tab >> under mpi types select openmpi

      or if using command line then add “-mpi=openmpi” without the quotes to the command line

      hope this helps

Viewing 2 reply threads
  • You must be logged in to reply to this topic.