Photonics

Photonics

Error running appopen in Linux

    • yoavli
      Subscriber

      I am trying to run appopen('fdtd') in a Linux environment and getting this error:

      Invalid MEX-file '/usr/local/lumerical-2021R1/api/matlab/appopen.mexa64': /usr/local/lumerical-2021R1/api/matlab/libinterop-api.so.1: symbol qt_version_tag, version Qt_5.12 not defined in file libQt5Core.so.5 with link time reference

      It used to work but all of a sudden it stopped. The IT staff at my institute don't know how to handle this. How can this problem be fixed? Are there some files that need to be installed?

      Thanks in advance

    • Lito Yap
      Ansys Employee
      From your message, "It used to work but all of a sudden it stopped."
      Do you mean it worked on a previous version of Lumerical and it is only happening on the latest release 2021 R1? What is the operating system of the Linux machine? Which version of 2021 R1 is having this issue? It seems to be having problem with the Qt libraries on your machine with our 2021 R1.
      Best Lito

    • yoavli
      Subscriber
      Hi Lito, thanks for your response.
      I am running MATLAB on a remote machine. What I meant was that it was running perfectly well and then after some unrelated crash where I could not connect to the remote machine, when it came back I started getting this error, on the same day. Maybe something happened, I need your help to know what to tell the IT staff to fix.
      My Lumerical version is 2021 R1.1.
    • Lito Yap
      Ansys Employee
      Based on the error message, it could be related to the Qt libraries. Try to ask them to check the QT libraries on your environment/path, i.e. LD_LIBRARY_PATH. What changes they made before or after the crash. The changes might be causing this issue.
      Best Lito

Viewing 3 reply threads
  • You must be logged in to reply to this topic.