Electronics

Electronics

Error while performing remote simulation: “Unable to create child process: 3dtds.”

    • gabrielfs
      Subscriber

      Hi all,


      I've been consistently running into the same error whenever I try to perform a remote simulation (through the HPC and Analysis Options).
      The error is:
      "Unable to create child process: 3dtds. Please contact ANSYS technical support."


      I've looked for similar threads, but I haven't found solutions for this error - maybe my lack of familiarity with the software prevented me of recognizing a possible solution in different postings, I apologize if this is the case.


      The similar threads I've found suggest that this error is related to design issues, however there are two reasons why I strongly disbelieve this is the case, (i) the simulations are running perfectly locally, and (ii) the problem happens even when I load designs from the examples library (which should not have design issues).


      Just to give a little more background if it is valuable: I've been using RMxpert to create machine models and I am generating MAXWELL 2D and 3D designs from those. The problem arises whenever I try to solve the 3D designs remotely - 2D designs are solved remotely without issues.
      In addition, a few colleagues with the same server license are able to use the 3D remote simulation without problems - the only difference is that they were originally using a different version of the Electronics Desktop suite (as were the hosts, but those were updated).


       


      Any help is appreciated.


      Thanks in advance!

    • AndyJP
      Subscriber

      Student and demo versions, at least in the past, were restricted to physical desktop only operation. RDP sessions, both, terminal server and remote desktop, require enterprise licenses. It may be a license-related problem.

    • gabrielfs
      Subscriber

      Thanks for your response, Andy!


      However I don't think that this is a license-related issue because, as I've mentioned, other colleagues from my lab are able to perform Maxwell 3D simulations remotely. And (maybe I was not clear about that in the original post) I am using the same license as they are, which is a research license by the way - probably different from the student and demo versions you were referring to.


      Fortunately, the Maxwell 2D simulations may just do the trick for the application that I am aiming for, but it would be really nice to have the 3D simulations ready to go if I needed. 
      I will keep looking into that and any further help is appreciated.
      If I find a solution in the meantime, I will make sure to post here!


      Cheers! 

    • gabrielfs
      Subscriber

      Quick update... I did not solve the problem, but I've found a workaround.


      I was originally running the simulation on the Electronics Desktop 2020R2. I've decided to install 2020R1, same version that some of my lab colleagues were using, and give it a shot. The Maxwell 3D remote simulation worked with version 2020R1.


      It's definitely not the optimal solution, but it may work for some.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.