General Mechanical

General Mechanical

Error!Update failed for the Model component in Static Structural. Conversion Failed.

    • Nithya
      Subscriber

      Hello,
      I am quite new to ANSYS. 
      I have a FEM file created in NX and choose the solver as ANSYS (for the solution). When I tried to load the .inp file created from NX into ANSYS (External model --> Model cell of static structural) i get the below error:


      'Update failed for the Model component in Static Structural.  Conversion Failed. [AcmoAcmoMeshProvider.cpp:82] ElementEnumeratorImpl: No elements'


      I also later tried with a very simple test model guessing the problem could be with the mesh, but this error has been consistent. I have no idea about the reason for this error and on how to resolve this! Please let me know.

    • Karthik R
      Administrator

      Hello,


      Could you please create a neutral file format (parasolid or STEP) of your CAD model and try to load it in Ansys Mechanical?


      Thanks.


      Karthik

    • Nithya
      Subscriber

      Hello Karthik,
      Thanks for the response. This is not a problem, I can load the CAD files without any error into ANSYS Mechanical. But, my efforts here are to load an NX FEM model into ANSYS (and not just the CAD model). As I have already done a simulation in NX  (generating the mesh, applying the boundary conditions and loads etc.) I do not want to spend time and efforts to re-do all of this in ANSYS again!

      I got aware that NX and ANSYS have an environment to support each other to also load the FEM files; the mesh, BC and load data would get written into ANSYS language automatically (by exporting .inp file from NX).
      I am currently getting the above error when I try to open the .inp file in ANSYS. I am unsure where the exact problem is. Because the .inp file does not state any errors as such.

      Thanks, 
      Nithya

    • Aniket
      Ansys Employee


      These are the only external model formats that you can import in Ansys Workbench.


      More info at:


      https://ansyshelp.ansys.com/account/Secured?returnurl=/Views/Secured/corp/v195/wb2_help/wb2h_ModelLoadapp.html


      -Aniket


      How to access Ansys Online Help Document


      How to show full resolution image


      Guidelines on the Student Community


      How to use Google to search within Ansys Student Community


       

    • Nithya
      Subscriber

      Hello Aniket,
      Thanks for the response. I exported the .dat format and it loaded in ANSYS external model successfully. Earlier the problem was that i was trying to import a .inp file into ANSYS from Nastran!

      Now I am able to see the mesh and also the loads in ANSYS, tough the simulation is giving an error 'Internal Solution Magnitude Limit Was Exceeded'. 
      I read the solution to this error in ANSYS troubleshoot. But, the problem now is that i am neither able to edit any forces nor see there magnitude in ANSYS. Please let me know a possible solution for this problem.

      Regards,
      Nithya

Viewing 4 reply threads
  • You must be logged in to reply to this topic.