Topics relate to Fluent, CFX, Turbogrid and more

Floating point exception error

    • javat33489

      Hi all.

      Earlier I solved a test problem with wheel rotation.



      She made a successful decision. Changed weight and inertia..

      Now I enlarged the wheel, made it longer, and added paddles inside and out.

      All settings are the same.

      But the task started to give an error:


      I can't find a priic because I tried everything:

      1.I included implicit in 6DOF

      2.I refined the grid to 10 million cells, although the single wheel version contained only 800k.

      3.I tried all methods (coupled, simple, piso).

      4.I also reduced the time steps and added a lot of sub steps.

      Nothing helps.

      During the solution, I noticed that the following error would appear in the console:

      In addition, after the error I checked the pressure:

      I carefully checked all the boundary conditions, they are all set in the norm, at the inlet the flow rate is 2.9 l / s, at the outlet the pressure is 12 MPa, 5 inputs from above at 4 MPa. The liquid to be transferred is water.

      What could be the reason? Thank you.

    • Rob
      Ansys Employee

      I'm assuming the screw is inside a pipe, and that it's not touching the sides? Do the blades interact with anything else or is it a standard Archimedies screw? 

      • javat33489

        No, the screws do not touch the walls, only with water.

        I solved the problem after 150 tries.

        The problem was solved thanks to a very small time step 1e-8. Grid with skewness less than 0.8.


        But I have a new problem due to pressure. I will make a separate post.

    • Rob
      Ansys Employee

      Good to hear. Read up on sliding mesh as that may be a better alternative. 

Viewing 2 reply threads
  • You must be logged in to reply to this topic.