Fluids

Fluids

Floating point exception in Fluent

    • gordongn
      Subscriber

      I am doing a counter-flow heat exchanger simulation in ANSYS student version.


      After I setup, I always got error "floating point exception"  in calculation.


      Please can somebody solve my problem?


       


      Intialization result:


      n


       


      During calculation:



      Error:



       


       


       


      There are my all the details:


      Details:


       



       


      It is recirculated exhaust gas heat exchanger which used in gas turbine. It is 200mm long with 60mm diameter.


       


      In my geometry, this heat exchanger consists of three parts, hot air fluid domain (outer domain) , 4 solid pipes and 4 inner fluid domain (2 methane and 2 air). As you can see, there are 8 interfaces in total.




      This is my meshing. I used adaptive sizing function to get less cells (119610 nodes and 326512 elements). And 4 edge sizing for pipes (20 Division hard). I don't use culvature size function because it will lead to 3300000 elements which I can't run it in student version.


       



      This is my skewness data.


       


      However, in my setup part. There are my setting.


      Pressure-based


      Absolute


      Steady


      Density on Y direction 9.81


      Energy Equation On


      Viscous - Realizable k-e Scalable Wall Function


      Materials are air, methane and steel



      Cell Zone Conditions.



      I didn't coupled my interfaces in Mesh Interfaces.


       


       



       


       


      In my Boundary Condition. There are 2 air mass- flow-inlet, 2 methane mass-flow-inlet, 1 hot mass-flow-inlet. And 5 pressure outlet in total.


      All the wall material has been set to Steel.


       


      If you need more details, please leave a comment.


       


      Thank you very much!


      Gordon

    • Karthik R
      Administrator

      Hello Gordon,


      Here are some suggestions about your model:



      • Your mesh skewness is really high. Please try to maintain this value below 0.95. 

      • Please try to use conformal mesh (rather than non-conformal). This will remove all your mesh interfaces and reduce your model complexity. You will have to perform 'share topology' in SpaceClaim. Here is an excellent video on how to.




      • Please make sure you have sufficient boundary layer mesh corresponding to y+ ~ 40, since you are using scalable wall functions.


      I hope this helps you overcome your convergence issues.


      Thanks.


      Best Regards,


      Karthik

    • BaqerAlzaki
      Subscriber
      Dear all,nToday, I want to guide you through all the possibilities that could solve this problem, and, in the end, I will give a solution to this problem that will 99% will work with all the cases and solve all the problem related to this issue, especially in the dynamic mesh.nFirst of all, you need to make sure these things:n1-Your mesh is set to CFD, fluent and NOT mechanicaln2- Your mesh should have at least a good skewness and orthogonal array valuen3- you have unstructured mesh, with tringles arrangementn4-your mesh should show all the bodies of your geometry without cutsn5-If it did not initialize properly, reset the setting and do it againn6- for transient application, take PISO as your methodn7- your timesteps must be less than 0.005nFinally, the real setup that really can solve this problem in the dynamic mesh is to activatenImplicit Update SettingsFor transient problems, you can enable implicit mesh updating when you want to have the dynamic mesh updated during a time step (as opposed to just at the beginning of a time step). This capability is beneficial only for applications in which the mesh motion depends on the flow field (for example, cases that use the six DOF solver or involve fluid-structure interaction). For such applications, having the mesh motion updated within the time step based on the converging flow solution results in a stronger coupling between the flow solution and the mesh motion, and leads to a more robust solver run. Implicit mesh updating allows you to run simulations that otherwise could not be solved or would require an unreasonably small time step. quoted from Ansys help centernThe main reason for this error is usually not the mesh that is not good enough, but the software cannot cope with the changing in the dynamic mesh, so the developers added this technique(Implicit Update Settings) to solve this problem.nThank you all ..nBaqer
Viewing 2 reply threads
  • You must be logged in to reply to this topic.