Fluids

Fluids

Floating point exception: Overflow

    • Gokkul
      Subscriber

      Hello everyone

      I am doing steady state 3D simulation for turbine. Before assembling the whole turbine, I tried simulating only the first stator. Everything was fine and I was able to get results. But when I am trying after assembling 2 stage turbine, I am getting errors like "Floating point exception: Overflow" or "Fatal Overflow of linear solver" before 10th iterations. So I tried simulating the first rotor alone, I am getting the same error. The mesh analysis has no error and even in the CFX solver, under mesh statistics, everything says OK. I tried using different mesh from coarse to very fine mesh. I can see that only the rotor has the error. I am using SST for turbulence model. The heat transfer model is Total Energy. Also, with the same rotor geometry and mesh, when I tried Air at 25C as fluid the simulation ran without any errors. The error pops up when I use Air as Ideal Gas. That's why it was very confusing and don't know where exactly the problem is! I created backup file before the error and when I was post-processing the results, the magnitude of velocity is too high (1.9e3).

      It would be great if someone could assist me in this situation. If needed I can share my mesh file or CFX file.

      Thanks in advance!

    • rfblumen
      Ansys Employee
      The error "Floating point exception: Overflow" means that a number is being generated that is too large to store. It could be related to dividing a number by a very small number. Some things to try:
      -Review the boundary conditions to make sure they're reasonable
      -Run in double precision.
      -Try with a smaller time step
      In order to understand what's happening in the model, it's helpful to run the model to just before it crashes and look at the solution in CFD-Post. The out file gives minimal information on the cause of the crash - to find out you need to look at the solution. Plot velocity vectors over the entire domain and look where the max vectors are and see why.
      If using a massflow outlet, sometimes the massflow is maldistributed at the outlet giving rise to high velocities. To fix this, set the option to constant flux


Viewing 1 reply thread
  • You must be logged in to reply to this topic.