Fluids

Fluids

Fluent on HPC cluster, error regarding -cflush

    • helen.durand
      Subscriber

      Hello ANSYS forums,


      I am currently running a Workbench simulation with Fluent on a HPC cluster, and I have been receiving the following warning when opening Fluent.


      WARNING: Rank: 0 Machine wsu182 has 79% of RAM filled with file buffer caches
      This can cause potential performance issues. Please use -cflush flag to flush the cache.

      Does someone have any insight into what this means exactly? 


      I know that the nodes are being shared among many users. When it says that 79% of RAM is filled, is it referring to 79% of the RAM on the entire node, or is it referring to 79% of the RAM allotted to my simulation?


      Also, I was unable to figure out how to use the -cflush command. 


      I noticed that another user has previously posed a similar question that has not been answered (see: https://studentcommunity.ansys.com/thread/running-fluent-on-cluster-clear-node-cache/?order=all#comment-4328dd1e-45ec-4734-b16a-ab9500ea4ba8).


      Thank you for taking the time to look into this.

    • Karthik R
      Administrator

      Hello,


      The warning message is saying that the OS is not, by default, freeing up the file cache buffer immediately even after the Fluent session exits.


      This would need manual intervention. Please make sure that the machines are idle and no jobs are running on the machine. Otherwise, running jobs are adversely impacted.


      Please try these following instructions. It is best if your IT handles these. They should be able to script this.


      You should be able to drop cache via “/sbin/sysctl vm.drop_caches=3”


      This option requires “sudo” privilege for setting /sbin/sysctl vm.drop_caches=3.


      This option is instantaneous.


      This option can be invoked via scheme command as shown below two examples. You can choose any one of them as per your convenience. o (%node-run -1 "sudo /sbin/sysctl vm.drop_caches=3")


       I hope this helps.


      Thanks.


      Karthik

Viewing 1 reply thread
  • You must be logged in to reply to this topic.