Topics relate to Fluent, CFX, Turbogrid and more

Fluent pressure problem

    • javat33489

      Hi all.

      I'm simulating the rotation of a wheel with water pressure using 6DOF. Previously, I made a test model with one wheel, at the inlet I had a flow rate of 1 l/s at the outlet atm pressure and at the second inlet atm pressure. The wheel turned and sucked water from the entrance and from the second entrance. Everything was ok.

      Previous post links:




      Then I complicated the task, I increased the wheel, added more blades on top and inside. All settings are similar, because the task remains the same as in the first option. The boundary conditions have changed, now at inlet 1 the flow rate is 2 l/s, at the outlet the pressure is 12 MPa, and at the second inlet (inlet 2)  the pressure is 4 MPa. I need the wheel to spin and take water from port 2. I need to see if this will work.

      I made a good grid, it is 7 million cells, while the skewness is 0.88.

      SST model. Simple method.


      But when I run the task, I immediately see repeated 6DOF has not converged warnings. I also see from the graphs that the pressure jumped out a lot, after a while I get a Floating point exeption error and the calculation is completed.

      I believe that the problem is in the second input (inlet 2) 4 MPa. Then I decided to check and put 12 MPa there as well as at the outlet. Then I received at the very beginning of the warning 6DOF has not converged and they did not appear anymore, and the task was solved successfully.

      I waited until all the pressure and flow graphs aligned, and the torque on the spinning wheel was equal to 0.

      Then I stopped the calculation and again made the pressure at the second inlet 4 MPa. Everything went well.

      The flow began to stabilize and there was a sharp jump in all indicators.

      How to fix it? Thank you.

    • C N
      Ansys Employee

      Hello Javat,

      I recommend you to check on the boundary conditions and values of your input parameter . Please raise a service request on salesforce for specific query and exact solution for your problem. 


      Chaitanya Natraj

      • javat33489

        Excuse me sir. After writing this article, I checked the settings again, it turned out that I indicated supersonic instead of pressure. I fixed it, but the wobble issue remained. I will hand over a new post with new screenshots. This post can be deleted. Sorry.

Viewing 1 reply thread
  • You must be logged in to reply to this topic.