Fluids

Fluids

fluent setup:error occure

    • veera
      Subscriber

      Dear sir


      i am simulating the In-cylinder (ic engine simulation) , with dynamic mesh (hybrid mesh), with DPM (diesel liquid), and species (diesel-air)


      i am using k-e rng -eddy dissipation with volumetric.


      initial conditions: chamber pressure 70bar and 713k 


      DPM injection from the surface with 183 m/s  for the crank angle of 337-350 - in boundary condition i kept that surface as the wall with escape 


      i am facing following errors


      1. invalid cp (1.000000+00) for species (ex:nitrogen, diesel-air) zero (k)nan


      2.turbulent viscosity limited to viscosity ratio of 1.000000e+5 for cell xxx (near half the total cell)


      3.divergence detected in AMG solver: temperature


       4. Temperature limited to 1.0000e+5in xxx cellson zone domain xx

    • Rob
      Ansys Employee

      Try with constant material properties for cp, k etc and see how it behaves. Have you got the mesh working yet?

    • veera
      Subscriber

      no sir, it's not happening, in layer sets, I tried the height with split factor1 also, but it's not happening.


      pls try to give answers for above all the questions


      questions 2, 3, 4


       

    • veera
      Subscriber

      hi sir, i run with a constant value, see initially i am started the problem with invalid cp in n2 , if i modify range in material parameters , after few itteration its showes invalid cp in diesel-air mixture


      n2


      h20


      co2


      o2


      this are my mixtures


      suppose, i switch off  species and DPM model, the dynamic mesh is working properly with solution converged


      pls help me to resolve this problem

    • Rob
      Ansys Employee

      4 will cause 1 and which likely triggers 3.  2 may be related to 4 but may also be boundary condition or settings related. 


      If the mesh runs OK try it with single phase, does it work, and is the mesh skew good enough? 

Viewing 4 reply threads
  • You must be logged in to reply to this topic.