Ansys Products

Ansys Products

Fluent through VPN not working, how to fix?

    • SaraB
      Subscriber

      Hello, I am trying to use my university academic license by connecting through a Cisco VPN, but unfortunately Fluent is not working for me.

      I installed Ansys 2020R2 (full version, not student) and added the license server IP in the anslic_admin utility.

      Initially, when I tried to run Fluent I got this message:


      ANSYS LICENSE MANAGER ERROR: Capability Fluent Solver does not exist in the ANSYS licensing pool.

      No specified user license preferences match available products in the specified license path:

      ANSYSLI_SERVERS: [email protected]

      FLEXlm Servers: [email protected]

      Hit return to exit.

      Unexpected license problem; exiting.


      I tried to follow some of the suggestions I found on the forum and now this is what happens:

      -standalone Fluent doesn't give me any errors, however it does not load completely and I have to kill the process via task manager.

      -if I try to open Fluent from Workbench it opens very briefly saying "Unable to connect to external socket: Error during socket creation", then it closes with the message "The Fluent application failed to start"


      Here's what I tried so far:


      -checked that the ports 1055 and 2325 are open

      -checked for firewalls

      -deleted license preferences in %appdata%

      -added the following on the ansyslmd.ini file:

      ANSYSLI_TIMEOUT_FLEXLM=15 

      ANSYSLI_FNP_IP_ENV=1

      ANSYSLI_FLEXLM_TIMEOUT_ENV=15000000   


      When I run the license status diagnostic I get the following message:


      Jul 08, 2021 12:53: Attempting to display the license status...

        ====================================================================================================

      DISPLAY THE LICENSE STATUS:

      ANSYS Licensing Interconnect path = [email protected]

      ANSYS FLEXlm license path = [email protected]

      ***** Note: Due to a FLEXlm limitation, all tasks may not be found *****

      <================================================================================>

      <================================================================================>

      ***** LICENSE SERVER STATUS: [email protected] *****

      lmutil - Copyright (c) 1989-2015 Flexera Software LLC. All Rights Reserved.

      Flexible License Manager status on Thu 7/8/2021 12:53

      [Detecting lmgrd processes...]

      License server status: [email protected]

        License file(s) on mme144011: C:Program FilesANSYS IncShared FilesLicensinglicense_filesansyslmd.lic:

       mme144011: license server UP (MASTER) v11.16.5

      Vendor daemon status (on mme144011):

       ansyslmd: UP v11.16.5

      Feature usage info:

      Users of 1spacdes: (Total of 550 licenses issued; Total of 0 licenses in use)

      Users of a_catv6_reader: (Total of 550 licenses issued; Total of 0 licenses in use)

      etc...


      Could you please help me solve this issue?


      Thank you very much!


      Sara

    • George Karnos
      Ansys Employee
      Hello Sara On the license server the daemon ansyslmd will be using a port also.
      This port should also be opened in the firewall exceptions.
      We recommend that if firewalls are in play that the license file be edited to give ansyslmd a static port as by default it is dynamic.
      The vendor line can be changed as follows to give the ansyslmd a static port of 1056
      VENDOR ansyslmd PORT=1056
      once edited and saved, the license manager would need to be restarted and 1056 would need to be added to all firewall inbound and outbound exceptions
    • SaraB
      Subscriber
      Dear Geo thank you very much for your reply. I will try to contact the license manager to do that.
      Anyway in the meantime I have managed to make Fluent work by following this step:
      set MPI Types to msmpi , select IP interface: 127.0.0.1
      After doing this once, now Fluent works even with the default MPI and IP interface options.

      Best
      Sara
Viewing 2 reply threads
  • You must be logged in to reply to this topic.