Fluids

Fluids

Fluent with GPU not starting

    • mechE
      Subscriber

      Hello, 

      I am trying to start Fluent 2022 R2 in gpgpu mode (by using the native GPU solver option on the Fluent start screen). However, I see the following error and Fluent stops responding as soon as it starts - 

      GPU Solver (Beta) enabled

      999999 (C:\ADOagent\_work\2\daily_dev22.2\ansys_inc\v222\fluent\fluent\multiport\src\mpsystem.c@1236): mpt_read: failed: errno = 10054

      999999: mpt_read: error: read failed trying to read 4 bytes: Invalid argument

      ===================================================================================

      = BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES

      = RANK 0 PID 7336 RUNNING AT ANSYS-CL-36

      = EXIT STATUS: -1073740791 (c0000409)

      ===================================================================================

      I have the following GPU on my machine - 

      CUDA visible GPUs on ANSYS-CL-36

      CUDA runtime version 6000

      Driver version 9020

      Number of GPUs 1

      0. Quadro K620

      3 SMs

      1.124 GHz

      2.14748 GBytes

      Any ideas on why this doesn't work? Would appreciate any help on this!

    • Rob
      Ansys Employee

      It is a beta feature.... Check the gpu is on the supported list, and that you are attached to the Uni licence server. 

    • mechE
      Subscriber

      Thank you for the response Rob. Based on the Fluent 2022 R2 release notes my gpu should be supported - 

      "Fluent supports NVIDIA's CUDA-enabled workstation, data center and server cards." 

      Also, I am trying this on campus, so I am connected to the license server for sure. I can start and run Fluent in regular parallel CPU mode without any trouble.

      Any other ideas on things to try?

       

       

    • Rob
      Ansys Employee

      There's the usual "update the drivers" and also, run "nvidia-smi" from the DOS window. I assume you're not trying to autoload a case, and have 3ddp selected?

Viewing 3 reply threads
  • You must be logged in to reply to this topic.