Topics relate to Fluent, CFX, Turbogrid and more

fluid falling into itself in multiphase simulation

    • dmr011

      I have a simulation with two phases (a gas phase and a liquid phase) the liquid is specified to be at the bottom of the container and the gas in the top. When I initialize everything I patch in the concentrations of the liquid mixture into the correct location and check to make sure the concentrations, density, and phase specifications are correct. When I run the transient simulation without any input that could induce fluid motion the liquid falls into itself and the level drops. The velocity is at almost 1 m/s. There are no inlets or outlets in the geometry and the density doesnt change. The velocity of the fluid is straight down in the liquid and straight up in the gas phase. Does anyone know why this is happening? I can't think of how this could be happening. I have other simulations with a nearly identicle setup and don't have this problem.

    • SRP


      Please provide the following details which will help to understand the issue:

      1) Geometry

      2) How do you patch both the phases in the geometry?

      3) What are the boundary conditions?

      4) Which multiphase model do you implement?

      Thank you

    • Nikhil Narale
      Ansys Employee

      In addition, post a screenshot of the volume fraction contour at a mid section plane after patching. 

      While patching water in the appropriate zone/register, make sure to set the VF to 1. 

    • dmr011


      Here is a picture of the vertical velocity field after 28 time steps, with each step being 0.00025 seconds. The upper portion is gas phase and the lower portion is a liquid mixture that is primarily water. The geometry is cylindrical except for the channel on the right side where there is a flat wall. The interior geometry is seperated into two regions of fluid that can be easily identified in the attached picture. 

      For patching, I patch the volume fraction of each species in the mixture for the liquid then patch the volume fraction of water as 1 as the last species. The gas phase is simply one component and also patched as a volume fraction of 1. 

      All boundary conditions are set to zero flux. The only boundary conditions with motion are the inner cylinder which is rotating at 41.88 rad/s about the central axis. I have also tried without the rotation and it gives the same issue. I am also setting electric potential boundary conditions at the flat wall on the right (1V) and the central third of the inner cylinder that is submersed (-1.2V). However, I also get this issue when I set both potentials to zero. There are supporting ion concentrations of 0.1M in the mixture. I also don't have any thermal effects activated. 

      I am using the volume of fluid multiphase model. I have also attached a screenshot of those settings. 

      The problem does seem to go away when i deactivate the electric potential model. I am trying to model electrochemical reaction in this aqueous system though, so the potential is going to be necessary. 

      Any ideas?

Viewing 3 reply threads
  • You must be logged in to reply to this topic.