3D Design

3D Design

Geometry editor was closed abnormally

    • saadabbas
      Subscriber

      I have downloaded "Ansys 18.2 (3.9 GB) Student version" to implement the FEA but unfortunately i couldn't be able to open the geometry. Every time i open it i get the error "Geometry editor was closed abnormally"


       


      I looked for the solution but didn't get the proper answer.


       


      Your help will be highly appreciated.


       


       


       


       

    • Vishal Ganore
      Ansys Employee

      Looks like windows file registry issue. Could you please open Workbench by "Run as Administrator" option and see if that helps? 

    • saadabbas
      Subscriber

      No, it doesn't work as well .

    • Vishal Ganore
      Ansys Employee

      Ok. You can try this. Let me know if it works.


      Step 1:


      Go to product installation path: C:Program FilesANSYS Studentv182commonfilesconfigswinx64config


      Run as Administrator: AnsConfigSpaceClaim.exe


      Step 2: Run file “regedit.exe” from windows, go to view> say "Refresh" then search for folder "SpaceClaim.AnsysSCDM.182"


      Make sure that SpaceClaim path is correctly listed based on your installation area. Restart your PC and open Workbench.



       


       

    • hamzah
      Subscriber

      hi i have win 7 64bit with the same problem when i run the mesh on fluent model a message appear and says, the geometry editor was closed abnormally


      i have tried  all the solution above  but it didn't work please help.

    • Jheferson_ga
      Subscriber

      hello. I have the same problem too, when I start a new project of Design Assessment the second step is make a geometry to work, but at the moment of start the SpaceClaim, Ansys shows that message. then I close it and can make my figure, but when came back to the Workbench... it doesn't receive the archive. 

    • Vishal Ganore
      Ansys Employee

      Unsupported graphics card could be the problem. Could you please check whether you have ANSYS supported graphics card (NVDIA or AMD) in your system?


      In the RUN command type: dxdiag , go to display and check the graphics card. 


      Also, are you using any integrated graphics card?


       

    • Vishal Ganore
      Ansys Employee

      Please review this document for ANSYS supported graphics cards. 


      http://www.ansys.com/-/media/ansys/corporate/files/pdf/solutions/it-professionals/platform-support/graphical-display-graphics-cards-tested-182.pdf?la=en-in

    • asnalb
      Subscriber

      Hi! 


      I am not entirely sure what the reason of this might be, but I get the same error message after installing the software on a machine with Windows 7, whereas it works totally fine on Windows 10. 

    • mohamed gamal
      Subscriber

      I did the steps above, but still have the same problem. as I can't open workbench, it appears as an unsaved project 

    • Sadilov
      Subscriber

       Was somebody able to solve this problem?


      I have Win 8.2 (64x) and GeForce GT 740 M

    • peteroznewman
      Subscriber

      Try downloading and installing the latest driver for your graphics card.

    • Hardikthakker
      Subscriber

      I too I am facing the same issue. I tried all the steps mentioned here but nothing solved the problem. Looking for a solution. Thanks

    • Imran7
      Subscriber

      Hi everyone, It seems the issue is yet to resolve as I did not see any proper solution to how to fix this geometry editor error. I am using Ansys Student 19.0 version and having the same error. After going through the comments, I did check "SCDM" configuration through "regedit" and installation directory and have updated the graphics card driver "NVIDIA GEFORCE"; BUT the error is still there... Can someone share the success story to remove the error.


      Thanks 

    • peteroznewman
      Subscriber
    • Jacuku
      Subscriber

      Getting these errors in Ansys 18.2


      Geometry editor was closed abnormally


      One or more parts were found to be unmodified so smart updated.


       

    • peteroznewman
      Subscriber

      Did you work through the Try this list above?

    • Hardikthakker
      Subscriber

      I did work through the suggestion. But this did not solve the problem. Additionally, based on that thread I would like to add that space claim opens fine. But when I try to open the 'new Geometry Design Modeler' I get the above stated error. 


      Thanks and regards,


      Hardik.

    • Jacuku
      Subscriber

      Did you work through the Try this list above?


      Tried but still getiing the same error. I am using windows 10 64bit.


    • quietstrive
      Subscriber

      I have the same problem in window 7 64bit.

    • Vishal Ganore
      Ansys Employee

      Run regedit.exe as administrator.


      Do you see the folder "HKEY_CLASSES_ROOTSpaceClaim.AnsysSCDM.182" under registry editor?

    • Hardikthakker
      Subscriber

      Yes I can see the folder under regedit.exe 



      P.S: I am using ansys 19.1 so I see HKEY_CLASSES_ROOTSpaceClaim.AnsysSCDM.191

    • Jacuku
      Subscriber

      It's been a week and still the geometry editor getting closed abnormally and I am unable to use the ansys for my work.


       


      Tried everything that is posted here and still the issue has not been resolved.

    • Vishal Ganore
      Ansys Employee

       I have a couple of suggestions here for everybody.


      1. Check whether you have right ANSYS supported graphics card. See here (other graphics card are generally not supported): https://www.ansys.com/-/media/Ansys/corporate/files/pdf/solutions/it-professionals/platform-support/graphical-display-graphics-cards-tested-17.pdf?la=en&la=en


      2. If you have two graphics cards (integrated + professional) then make sure that you are setting supported graphics card as primary.


      3. Rename %APPDATA%AnsysvXXX directory to .old , reboot and try again.


      4. Run productconfig.exe and install all prerequisites needed (if any).

    • ewan_matheson
      Subscriber

       Tried all of your suggestions and nothing has worked. Any other options?

    • peteroznewman
      Subscriber

      I assume your computer does not have a graphics adapter on the tested list.


      Your best option is to purchase an adapter from this list. That doesn't guarantee your computer doesn't have some other issue preventing the software from running. If you were also to format the hard disk and reinstall a fresh copy of Windows, then ANSYS, that is what the testing has validated will work.


      Another option is to rent time on a cloud computer, but that is probably more expensive in the long run that buying a new computer.

    • jose.parambil
      Subscriber

      I too have the same issue with Ansys 19.0. (Windows 10, 64 bit).


      I am able to open SpaceClaim independent of Workbench. But, when opened from Workbench, I get the message that "The geometry editor was closed abnormally". Further, the workbench does not save any work from SpaceClaim. I am able to save geometry files directly from SpaceClaim.


      My registry does have the HKEY_CLASSES_ROOTSpaceClaim.AnsysSCDM.190 file and the folder path is correct. I do not have any external graphics card installed.


      Tried the solutions listed here, but nothing worked. Kindly help in this. Thank you.

    • peteroznewman
      Subscriber

      As a work around, try the following:


      1) Open SpaceClaim from the Windows Start menu, create some geometry and save that file.


      2) Open Workbench and drag a Static Structural or something with a Geometry cell followed by Model or Mesh.


      3) Right click on Geometry and Import the file saved in step 1.


      4) Refresh Workbench


      5) Open the Model or Mesh cell.


      Does that get the geometry into Mechanical or Mesh?

    • DeathFly
      Subscriber

      Hello! I've got the same problem and none of the solutions listed above helped. I've tried steps you asked to check and found that after refreshing Workbench the error  "Geometry editor was closed abnormally" pops up again. Also I'm not sure if my graphics card NVIDIA GeForse GT 710M is being supported. 

      Thanks in advance.

    • peteroznewman
      Subscriber

      Hello DeathFly,


      Try turning off the Windows Firewall. It worked for one student.


      Regards,


      Peter

    • bitternectar
      Subscriber


      I tried everything above. It still doesn't seem to work. Any other ideas?

    • peteroznewman
      Subscriber

      bitternectar, you have a different problem than the title of this discussion.


      Please copy and paste your post into a New Discussion in Geometry, then delete the post you just made. Title: Unable to attach geometry.


      In your new post, also show two more images. 1) Click on the Geometry cell in Workbench and show the properties on the right side for Analysis Type, is it 2D or 3D?  2) Open SpaceClaim and show the Outline window on the left and the geometry window.

    • Kris
      Subscriber

      Hello,


      For the original message "Geometry editor was closed abnormally". I found that this is related to the graphic cards:


      For the users that obtain this message, it means that you have two graphic cards - one integrated to the mother board and one that usually should be used for softwares like ANSYS - let's say it is an Nvidia. So what I suggest is to go to the BIOS and instead of automatic choice (between the integrated card and the Nvidia) to chose the Nvidia card by default.


      Your monitor should be plugged to the port of the Nvidia card. You may need to go in the control panel and also chose to use the Nvidia card or even upgrade its drivers.


      I have obtained this information from a person who had this message and by doing the procedure described above, he managed to solve it.


      Regards,


      Kristian

    • w4821540
      Subscriber

      I was using ANSYS workbench 19.2 on win10 X64


      and the same problem came to me


      I did this: Tools>Options>Geometry Import >Preferred Geometry Editor,   change it from SpaceClaim Direct Modeler  to DesignModeler


      Then I can use DesignModeler instead space claim.

    • w4821540
      Subscriber

      I tried 3 ways:


      1. Run CAD configuration manager as administrator , then config spaceclaim direct modeler


      2.Change render from Direct3D11 to WRAP https://studentcommunity.ansys.com/thread/problem-opening-spaceclaim-using-ansys-18-2/?order=all#comment-cae8bf53-fb6f-4e2f-9c68-a88501467df1


      3.Run Product&CAD Configuration manager as administrator,  then "install requered prerequisites"  "add .net security....."  "configure products&CADs" choose ANSYS AIM 


      One of them worked, I can run SpaceClaim in workbench19.2 now

    • thansiyapa_gmail_com
      Subscriber
      Instead....nHKEY_CLASSES_ROOT\SpaceClaim.AnsysSCDM.202n
Viewing 35 reply threads
  • You must be logged in to reply to this topic.