General Mechanical

General Mechanical

Topics relate to Mechanical Enterprise, Motion, Additive Print and more

getting an error like invid body with zero volume while doing analysis in static strutural

    • sivamk
      Subscriber

      I imported model from catia to workbench and while doing meshing it is showing nothing but while obtaining solutions it is showing an error like invalid body with zero volume ,can any one please help in figure it out

    • Vigneswaran Sridharan
      Ansys Employee
      Hey If you set the thickness of your imported surface to any value you should get past the error message (invalid volume error) and your model will solve. If you change that thickness to any other non-zero value it will solve again AND the results will be the same as the first non-zero thickness analysis. So if you put in a non-zero value you can get Mechanical to solve and the thickness is irrelevant but necessary (as far as analysis without acceleration is concerned).
      If you click on the model at the geometry stage does the volume return a value (ie m^3)?
      Are you able to right-click on the message and go to problematic geometry? If not how many bodies are there in the tree? If there are few can you check the volume properties of each body: And see if it shows some finite and valid number? Once you isolate that body you can check the source for the body and repair or suppress it in CAD.
      Vigneswaran
      Ansys Help
      Rules & Guidelines ÔÇö Ansys Learning Forum
    • Poudan Kumar
      Subscriber

      Invalid body with zero volume pops when i try to solve.I am beginner and stuck with this problem.Could some one help?

      I am 

Viewing 2 reply threads
  • The topic ‘getting an error like invid body with zero volume while doing analysis in static strutural’ is closed to new replies.