Ansys Free Student Software

Ansys Free Student Software

Harmonic Acoustics Transmission Loss Results Error

    • David McCullough

      I am attempting to simulate transmission loss in a muffler and tailpipe using the harmonic acoustics module. I keep getting three different error messages:

      1. An error occurred when the post processor attempted to load a specific result. Please review all messages. (the most common error)
      2. The input power at the driven port is equal to zero. Please check the port definitions. (second most common)
      3. An error occurred inside the POST PROCESSING module. (least common error)

      I was first using Ansys Student 2023 R1 and thought there may be a bug in the software so I did a complete uninstall and tried Anysy Student 2022 R2, but am still having the exact same problem. 

      I have tried unchecking dstributed solve and using only one CPU core, but it is the same outcome as cheking distributed using 4 cores.

      I have tried different methods of creating geometry, including STEP import, IGES import, and creating the geometry from within DesignModeler. All have the same outcome.

      I have only gotten a result 2 times out of several dozen different attepts. The two results were with a very simple straight cylindrical geometry modeled in DesignModeler that was just an extrude by 12inches of a 4inch diameter circle.

      The only thing unusual I have noticed is the solution steps do not match the setting in Project>Model>Harmonic Acoustics>Analysis Settings>Options>Solution Intervals. Of the last three solve attempts, first I left it at the default 10Hz and it solved at 600Hz steps. Then I put 600Hz and it solved at 10Hz Steps. Then I put 1000Hz step and it solved at 6Hz steps. EDIT: Just realized "Solution Interval" is actually the number of steps and not the step amount in Hz. So this is no longer an issue. That's a bit counter-intuitive to me.

      Also worth noting, I set Project>Model>Harmonic Acoustics>Port In Duct>Pressure Amplitude to 0.5psi. Not sure why I am getting error #2 above.

      Does anyone have any suggestions or see anything i may have set up wrong?

    • David McCullough

      I was first trying to use "Port in Duct" definitions for the inlet and the outlet, then i came across another post and example that used a surface velocity specification so i used that method and i now get results for the Transmission Loss graph, but i still get the error when i try to do a plot of sound pressure level or a far-field mic result.

      I have no idea which method would be the best suited... surface velocity or Port in Duct. There doesnt seem to be much documentation or tutorials on how to set up and run acoustics. Any resources anyone can recommend would be very much appreciated!


    • Bill Bulat
      Ansys Employee

      Hi David,

      I'm not 100% certain this is the problem but I'm pretty sure the muffler inlet and outlet must be "flagged" as being ports to enable transmission loss calculations:

      For some excitation options this may be done automatically/transparently (I forget under what conditions this occurs, if it does). I believe that specifying an acoustic pressure at the inlet constitutes a "hard" boundary condition (waves reflected by downstream geometric discontinuities may not pass into the surface):

      Transmission loss calculations require two transparent ports:

      The application of an acoustic pressure BC on the inlet makes that surface reflective (not transparent). I think this is the problem you're hitting. Our documentation probably needs to declare this more explicitly. 

      I just worked up a quick test case. These BCs allowed the calculation of transmission loss for me (the inlet is on teh left):

      Hope this helps!



    • David McCullough

      Hey Bill,

      Thanks for the reply. That may have been one issue I was having and it seems to be resolved, but there is more going on here too. I quit using the "Port in Duct" specification and started using the surface velocity excitation and I am at least able to get results for transmission loss now. After a slove, I have to save and close the mechanical solver and reopen it before attempting to view the transmission loss results or the window locks up and i have to force a close. 

      If i try to solve any of the other results plots, such as "A-weighted Sound pressure level plot" the mechanical solver window locks up with the status bar showing "(5%) Resuming CAERep..."

      I must admit the help documentation is a bit confusing. It doesnt really explain which excitation or boundary conditions are best to use when. 


Viewing 3 reply threads
  • You must be logged in to reply to this topic.