Heat simulation of 2D material

    • ethank

      Hello everyone,

      I am trying to simulate heat conduction in 2D material (MoS2). The thickness of the 2D layer is 0.65nm and I am aware of the fact that it might cause some problems with meshing.

      My simulation is as follows: I have an imported heat source on the gold contacts (green) and I want to see the heat conduction on the 2d material (orange):

      These are the properties of my HEAT solver:

      I tried to change the max refine steps, the sensitivity, the min/max edge length, and the triangle quality. I also put a very dense mesh constraint around the 2d material, but I always get the next output:

      What should I do? What does this error "The point set is trivial" mean?

      Thanks a lot,


    • Khashayar Ghaffari
      Ansys Employee

      Hello Eitan,

      Thank you for reaching out and providing detailed information about the problem and your settings. Solving errors similar to what you have shared will require some troubleshooting. Based on the information available I have the following recommendations:

      1- Confirming where the error is coming from: As you suggested this is most likely related to the very thin sub nano-meter layer, or similarly the large aspect ratio (feature size vs total simulation region size). However, to be sure, please disable the "2D layers" and confirm whether you can obtain a mesh and run for this version of your project.

      2- Verify with a simpler version: There seems to be a uniformity in the third direction. If possible, I advise switching to 2D simulation to make the meshing less challenging. When successful you can switch back to 3D.

      3- Mesh size: Assuming there are no local mesh constraints added to your project, the current settings opt for a minimum edge length of 20 nm while your 2D layers are sub nanometers. I suggest:

      A) try reducing the minimum edge length in the solver's settings or adding local mesh constraints for the layers with smaller values.

      B) the issue might be related to the large aspect ratio. In that case Increasing the maximum and minimum mesh edge length will be helpful. I would suggest testing this if 3.A doesn't work.

      4- Finally, switching the volume meshing for 3D simulation could be helpful. Hybrid (your current choice) and advancing front methods could better success in generating a mesh for structures with thin geometries. More information about this option is provided in this article:

      Let us know if you have any questions as you make further progress here.

      Best regards,


    • ethank

      Hi Khash,

      Thank you very much for the response! I'll answer your suggestions section by section.

      1- I indeed ran the simulation without the 2D layer and it worked perfectly fine. So the problem is with the 2D layer.

      2- I cannot verify the simulation as a 2D simulation since there is no symmetry in any direction. I must run the simulation as 3D simulation.

      3-A- The example above is with a mesh constraint, and it didn't work.

      3-B- I tried to run it as you said, but my computer just can't stand it. It doesn't have enough resources.

      4- I also tried to run it as "Advancing front" but as it is said in the article you gave me, it doesn't support mesh constraint. So when I put minimu edge length that is in nanometer scale, it just doesn't work.

      I ran the simulation again with the mesh constraint, and I see that it is stuck for hours on the next job "SplitSeparateFaces":

      I mean, the simulation is running, and it consumes slowly the disk memory of my computer (about 40GB), and all this time it is stuck on "SplitSeparateFaces". What should I do?

      This is where the job manager is stuck at:

      I would be grateful for a response.


      Thank you very much,


    • pappu eleczo

      Wow Thankyou for the Great Explanation. can you Please Explain me How Anchor 10 Amp Switch Work??

    • Khashayar Ghaffari
      Ansys Employee

      Hi Eitan,

      Thank you for the information. In this case, you may try disabling the mesh constraint; this might be helpful since you mention having enough resources for meshing could be the bottleneck which makes sense given high number of mesh cells.

      Therefore, try disabling the mesh constraint, and then switching to advancing front. At the same time Increasing the values of max and min edge length (making the mesh coarser) could be helpful. I suggest testing different combinations of min and max, also in combination with different meshing methods (hybrid, advancing front, and vertex insertion). 

      This is certainly a challenging structure to mesh so finding the right settings to resolve the mesh could be time consuming. 

      All the best


    • Khashayar Ghaffari
      Ansys Employee

      Hi @pappu Are you using Lumerical? If so, please feel free to share your question in the Photonics section of this forum but as a new post. Thanks.

Viewing 5 reply threads
  • You must be logged in to reply to this topic.