Preprocessing

Preprocessing

Help for Mesh element reduction

    • KianaMousavi
      Subscriber

      Hi

      I have these wavy solids and I want to simulate airflow passing through them. I have subtracted these solids from the fluid domain. The main geometry I have is around 40*40 cm and the bigger rectangle for fluid domain is only 50 cm longer at each side.

      As the academic version does not allow for more than 512K mesh elements, how can I reduce this number? In my first try, I had around 46M elements !!! I tried reducing the number of divisions in the sizing. However, the element number increased to 49M.

      How can I reduce the number to under 512K?
      Should I suppress the wavy solids?


    • peteroznewman
      Subscriber

      80^3 = 512,000


      That means you can only put 80 elements along each direction of a cube of 40 cm, that means the element size must be < 0.5 cm or 5 mm.


      Aren't the features on those surfaces about 5 mm?  If so, you can't simulate an object of this size with features this small on the Student license.


      I recommend you cut it down to a smaller domain or get access to a Research license.


      You can see how a coarse mesh looks like on this geometry. Delete (or Suppress) all items under Mesh. Select all the faces of the bumpy object and use a Mesh Sizing on those faces of 5 mm.


      Set the Mesh to Defeature objects of 5 mm or less.  Turn off Adaptive Meshing and set the Element Size to 20 mm.


    • KianaMousavi
      Subscriber

      Thank you Peter! I will try this now!


      You suggested the above settings for the wavy geometry, should I make any changes to the fluid domain as well?


      I started using Fluent a few days ago so I'm sorry if my questions are stupid or too easy. I really appreciate your help.

    • peteroznewman
      Subscriber

      How did the bumpy solid look like at that mesh setting?  Was it too coarse?  Can you simulate a smaller domain?


      I suggest you just run the airflow in the air domain only, and leave out the solid material for a first test. You can use the same settings.


      You want Shared Topology when you create the air so that there is no contact needed between the solid and air.


       

    • KianaMousavi
      Subscriber


       


      Yes the mesh is too coarse with the above setting.


      I reduced the length of the fluid domain to half, and also reduced the wavy solid to half as it was an array of surfaces.

    • Keyur Kanade
      Ansys Employee

      Glad to see that you have got some mesh. 


      You have couple of other post going on with same issue. can you please keep only one post for meshing question. 


      Regards,


      Keyur


       


      If this helps, please mark this post as 'Is Solution' to help others.


      Guidelines on the Student Community


      How to access ANSYS help links


       

Viewing 5 reply threads
  • You must be logged in to reply to this topic.