HFSS Slow Frequency Sweep

    • kuhnk


      I am running a frequency sweep in HFSS to determine the bandwidth of a periodic waveguide.  The sweep is quite large (about 15 GHz) because we are trying to determine how effective our device is within the scope of the entire Ka-band.  I have simulated the same structure with small geometry deviations many times before and when HFSS is solving for frequencies, it has always done it by solving 4 frequencies in parallel. 

      Until about 3 days ago, HFSS is only solving 1 frequecy in parallel, thus quadrupuling my simulation time.  I have no other programs or applications open on my machine, the machine has 64 GB or RAM, I set the simulation priority to "highest," and I have restarted my machine numerous times.  As I mentioned, I have simulated numerous, almost identical, devices in the past, all of which have always been solved with 4 freuencies in parallel.

      I am on a very tight deadline for my research and I cannot figure out why this may be happening.  Any suggestions would be greatly appreciated!

    • Praneeth
      Ansys Employee

      Hi kuhnk,

      Did you disable HPC (High Performance Computing) by any chance?

      To run more than one frequency point in the sweep, you should have enabled it.

      In simple words, the tool allows you to run more than one frequency point at a time during the frequency sweep.

      You need to set the cores of your manchine and maximum RAM usage per core in percantage.

      More information can be found here - Ansys Electronics 2022 R1 - Working with Ansys Electronics Desktop Projects.

      Best regards from the Ansys team,


Viewing 1 reply thread
  • You must be logged in to reply to this topic.