Fluids

Fluids

High calculation time while obtaining RTD during two phase flow

    • Abhinav_Maurya
      Subscriber

      Unable to increase the time step size greater than 0.002s. Any greater time step leads to floating point exception error and once this error is obtained, irrespective of how smaller the time step size is kept, the error persists.

      Steps and method being followed:

      I. (Before tracer injection)

      1. Setup: realizable K-e, standard wall functions; Multiphase - VOF; Species transport: OFF

      2. Side Inlet: Air (Vol. frac 0); Top Inlet: Water (Vol. frac 1)

      Ran the simulation in steady-state, obtained converged solution post 20000 iterations.


      II. (During tracer injection) - Switched to Transient simulation

      1. Setup: realizable K-e, standard wall functions; Multiphase - VOF; Species transport: OFF

      2. Side Inlet: Air (Vol. frac 0); Top Inlet: Water (Vol. frac 1 but tracer mass fraction = 1)

      3. In the solution --> Controls --> Equation, Flow: Off, Volume Fraction: On, Turbulence: On, Tracer: On

    • Rob
      Ansys Employee
      Please describe the model: pictures are good. Running 800s is a long duration transient, so will take a fair time to complete.
    • Abhinav_Maurya
      Subscriber
      Correction: During Step II and Step III, Species transport: ON
      Mesh Details

      Model Information
    • Rob
      Ansys Employee
      If you turn off volume fraction & turbulence (frozen flow field) you may be able to increase the time step. If not as you're only solving one equation the solution should be significantly faster.
      As an aside, I really don't like wasting my time answering the same topic twice. https://forum.ansys.com/discussion/36009/tracer-amount-keeps-on-increasing-in-the-tundish-during-rtd-calcuation-for-two-phase-flow#latest
    • Abhinav_Maurya
      Subscriber
      I'll Try that sir. Thank You for the response.
      However, in the other post
      (Post Tracer Injection)
      1. Setup: realizable K-e, standard wall functions; Multiphase - VOF; Species transport: OFF
      2. Side Inlet: Air (Vol. frac 0); Top Inlet: Water (Vol. frac 1 but tracer mass fraction = 0)
      3. In the solution --> Controls --> Equation, Flow: On, Volume Fraction: On, Turbulence: On,
      [Method 1] Tracer: Off
      [Method 2] Tracer: On
      While following Method 1, the tracer amount doesn't increase in tundish. However, if method 2 is followed, the tracer amount keeps increasing with time. When the simulation was performed using method 2 for the homogeneous phase, the simulation ran smoothly.
      If you can please provide support in this as well, it will be a great help.
Viewing 4 reply threads
  • You must be logged in to reply to this topic.