Fluids

Fluids

Hooking define_turb_schmidt UDF

    • LukeM
      Subscriber

      I am using a DEFINE_TURB_SCHMIDT macro in my simulation. I wrote the code and successfully compiled it in Fluent, but I am unable to hook it to my simulation. I attempted to follow the instructions in the user's guide ("Hooking DEFINE_TURB_SCHMIDT UDFs"), including a careful selection of turbulence models and selecting the Species Transport model, but I was unsuccessful. In particular, the Viscous Model Dialog Box in my simulation did not have the Prandtl and Schmidt Numbers User-Defined Functions box. See below. 


       

      image.png
       
      This dialog box differed from the sample dialog box in the user manual. 
       
      Is there a reason why my dialog box is different? Do I need to select another model? 
       
      I attached a few more screenshots of my simulation.
    • DrAmine
      Ansys Employee

      Only single phase.

    • seeta gunti
      Ansys Employee

      I guess your are using multiphase multispecies model. You won't see the option for turbulent schmidt number for multiphase models. In our customization model, it is clearly mentioned. 


       



      For single phase, you can see the option as below



      Regards,


      Seeta

    • Keyur Kanade
      Ansys Employee

      As its for single phase only, can you please mark this as 'Is Solution' to help others on forum. 

Viewing 3 reply threads
  • You must be logged in to reply to this topic.