Fluids

Fluids

How do I resolve this floating point error in the fluid domain of my FSI simulation?

    • dxc200018
      Subscriber
      I'm doing an FSI simulation.
      (This isn't related to my last post. Its a similar simulation with a different geometry for the fluid domain)
      I start getting floating point errors in the fluid domain.
      "Divergence detected in AMG solver: x-momentum
      Divergence detected in AMG solver: y-momentum
      Divergence detected in AMG solver: z-momentum
      Divergence detected in AMG solver: pressure correction
      Error at Node 15: floating point exception
      Error at Node 16: floating point exception
      Error at Node 17: floating point exception"
      Is this related to my boundary conditions?
      I have 2 walls and 1 pressure outlet with a UDF imposing an exit pressure.

    • Karthik R
      Administrator

      Hello,

      Your dynamic meshing setup seems to be incorrect. You have picked up all the options - Smoothing, Layering, and Remeshing. What type of mesh are you working with - unstructured tetrahedral? Also, which surfaces are you having moving and deforming meshes? Could you please highlight in a screenshot?

      The divergence seems to be associated with your dynamic mesh settings. At what point in your simulation are you seeing this issue? Is it at the very beginning? 

      Thank you.

      Karthik

      • dxc200018
        Subscriber

        Sorry, my reply is in the other comment.

    • dxc200018
      Subscriber

      "What type of mesh are you working with - unstructured tetrahedral?"
      yes

      The error occurs at the beginning of the simulation.

       

       

Viewing 2 reply threads
  • You must be logged in to reply to this topic.