General Mechanical

General Mechanical

    • Andy
      Subscriber

      Hi, Mr. / Miss


       


      as of complexity of my model (static structural), I turned off the function of <<>> in workbench option, as graphics1, but when I update geometry and rerun, there is still some auto detected contacts.


       


      any one can save me from the boring feature, thanks a lot.


       


      Andy.


       


       

    • Sandeep Medikonda
      Ansys Employee

      Andy,


      Have you set "Generate Automatic Connection on Refresh" to No?



      Regards,


      Sandeep

    • Andy
      Subscriber

      Hi, Sandeep,


       


      looks this is the right answer, I get it now.


       


      thank you buddy.


       


      Andy

    • peteroznewman
      Subscriber

      Hi Andy,


      I prefer to permanently turn this automatic behavior off, for any new model, so I never have to deal with the problem.


      You do that in Workbench, Tools > Options... select Mechanical from the list, then uncheck Auto Detect Contact on Attach.



      Cheers,


      Peter

    • Andy
      Subscriber

      Hi, Peter,


       


      the first time I checked the options, I turned it off, , but still auto contact pairs added.


       


      this issue didn't solved until Sandeep's comments, set "Generate Automatic Connection on Refresh" to No. I don't know how the two options combines, but now it worked, with both of them turned off.


       


      thank you


       


      Andy

    • adamkovacs1126
      Subscriber

      Hi Sandeep, 


      how comes I cannot manage to find this option? 



      I also tried what Peter suggested but as for Andy, contact pairs are still added automatically during an update. I am using R19.1 Rigid Body Dynamics but I could not find the disabling option in Static Structural either.


      Thanks for the help and kind regards,


      Adam

    • Sandeep Medikonda
      Ansys Employee

      What I suggested is in a different location to what you are showing above:



      P.S: This Discussion has been marked to be locked as it has an answer. In the future, please open a new discussion and use the #Permalink to tag another. Take a moment to review the Guidelines on the Student Community.


      Regards,
      Sandeep

Viewing 6 reply threads
  • You must be logged in to reply to this topic.