Photonics

Photonics

How to fix this problem due to different version?

    • d08941008
      Subscriber

      Hi, there's a connection problem after I update to the version 221 of lumerical,

      the error message shows:

      /home/***/v221/bin/fdtd-engine-impi-lcl: error while loading shared libraries: libglut.so.3: cannot open shared object file: No such file or directory


      while it works fine when I use the older version of v212, with the engine path of /home/***/v212/bin/fdtd-engine-impi-lcl


      I've re-installed many times but it just couldn't reach the engine file.

      Although the elder version works fine, it really bugs me, can anyone help me with this?


      Thanks.

    • Lito Yap
      Ansys Employee
      As indicated on the error message, "error while loading shared libraries: libglut.so.3: cannot open shared object file". The latest release of Lumerical requires the libglut.so.3 libraries. Please consult with your IT to install the missing libraries. We have this article in the KB on how to check for the require libraries to run Lumerical on Linux. Hope this helps.
Viewing 1 reply thread
  • You must be logged in to reply to this topic.