Fluids

Fluids

how to force UDF to run in serial mode in fluent 19.0

    • jfzhang
      Subscriber

      I have a UDF code which has to be run in serial mode. However, fluent 19.0 always automatically converts it into parallel mode, which cause the UDF not able to run correctly.


      Please let me know how I can force the UDF to run in serial instead of parallel.


       


      Thanks

    • Karthik R
      Administrator

      Hello,


      Can you try this? Set the 'processing options' to parallel and set 'processes' to 0.



      Best,


      Karthik

    • jfzhang
      Subscriber

      Thanks for the reply.


      It doesn't work. Still runs in parallel mode.

    • Karthik R
      Administrator

      Hi,


      Could you please share a screenshot of the message you get? Please add a screenshot of your entire Fluent window.


      Thank you.


      Best,


      Karthik

    • Keyur Kanade
      Ansys Employee

      Hi, 


      Can you please let us know if you have UDF in serial mode or parallel mode?


      Please have a look at following where is shows difference in serial and parallel udf. 


      https://www.learncax.com/knowledge-base/blog/by-category/cfd/parallelization-of-udfs-in-ansys-fluent


      Also if you still get errors, please insert image of your udf. (Do not attach) 


      Regards,


      Keyur

    • jfzhang
      Subscriber

      Fluent automatically starts in the parallel mode.


      The UDF can be compiled and loaded. However, it doesn't do anything because they were written in serial mode.


      There is #if !parallel  ....  #endif  command.


      I want to find out how I can force fluent to start and run in the serial mode.

    • Karthik R
      Administrator

      Hello jfzhang,


      Please post screenshots of the messages you obtain. It is extremely difficult to help without having a look at the error message.


      Thank you.


      Best Regards,


      Karthik

    • raghava
      Subscriber

      HI, 


        Even I am facing the same issue. I am particularly specifying to run in serial but it starts in parallel. When I compile my UDF , I receive the following error when I try to build the UDF,


      "F:trialnext2d_filesdp0FLUFluentlibudfwin642ddp_hostlibudf.dll


      Error at Node 0: The UDF library you are trying to load (libudf) is not compiled for parallel use on the current platform (win64).


      The system cannot find the path specified.


       


      F:trialnext2d_filesdp0FLUFluentlibudfwin642ddp_nodelibudf.dll "


       


       


      When I try to load  it shows the following error 


      "


       


       


      ****************************************************************************


       


      ****************************************************************************


       


      ** WARNING: Automatically switched to run in parallel -t1 mode. **


       


      ** Detected non-parallelized UDF usage, enabling parallel usage. **


       


      ** If you encounter any issues, please re-run with -t0 flag. **


       


      ****************************************************************************


       


      ****************************************************************************Creating user_nt.udf file for 2ddp_host ..."


       


      How to implement the above mentioned setting with -t0 flag?


       


      I hereby attach the screenshots for your perusal.


      Kind regards,


      Raman 

    • ztdep
      Subscriber

      Dear sir : i met the same proglem with you. Have you resolve the problem?

    • Rob
      Ansys Employee

      If you look at the post by Karthik, you'll note you need to start in parallel with zero nodes: that forces the older style serial solver. However, if you only have one node most UDFs will work as though they're in serial.

Viewing 9 reply threads
  • You must be logged in to reply to this topic.