3D Design

3D Design

How to pick version of Solidworks used by the Workbench Plugin for cad import

    • ryan-feeley
      Subscriber

      Hi, does anyone know how to specify the version of Solidworks that is used by the workbench plugin when you import geometry from .sldprt or .sldasm files?

      I have Ansys 2022R2 on my machine, along with Solidworks 2020 and 2021. My part files are modeled in 2020, and I don't want to update them to 2021. When I try to import this geometry into Spaceclaim (I'm using Ansys Speos), the importer appears to use SWX2021 to convert them to the latest version (in memory only). For one of my files, the resulting rebuilt produces an error, so I don't have full faith in the resulting geometry.

      I want to use SWX2020 for both modeling and to do the import. The only way I can find to do this is to remove SWX2021 from my machine. Does anyone know about a different way?

      Regards,
      Ryan

    • George Karnos
      Ansys Employee

       

      Try the following:
      Make sure NO software is running: Solidworks or ANSYS

      Run the Cad Configuration Manager 
      (Start->Ansys 2022 R2->CAD Configuration Manager 2022 R2)(Right Click->more Run as administrator)

      Unconfigure the Solidworks Associative Plugin

      Exit the Cad Confiuration Manager.

      Run Solidworks 2020 just to make sure it was the last version of Solidworks run.
      Exit Solidworks

      Open the CAD Configuration Manager again and configure Solidworks Associative Plugin.

      Exit.

      Now try to import.

       

       

    • ryan-feeley
      Subscriber

      Thanks George,

      I wouldn't have thought to try that in a million years. I'm not sure if it worked through. I tried to run the Speos Geometry Update to update a swx2020 part when I has swx2020 licensed, but not swx 2021. The import tool generated a popup from swx2021 asking that it be licensed.

      Here is some of the output from the CAD configuration manager log after I did the final configuration. Is there any way to inspect the referenced "registry entries" to see what versions of solidworks they are pointing to?

      ----------------------------------------------------------------------
      <>
      File:  C:\Program Files\ANSYS Inc\v222\aisol\bin\winx64\ReaderHostU.dll
      Mode:  Configure
      Exit Code: 0  -- expecting 0
      Result:   Success
      CCMInfoFileXmlBackUpPath is:C:\Users\ryan\AppData\Local\Temp\CADConfigurationInfo.XML
      ______________________________________________________________________
      <>
      UpdateCADControllerInRegistry
      UpdateSoftareRegistry
      Discovery Workbench Plugin ..... Configure Success
      ______________________________________________________________________
      ______________________________________________________________________
      <>
      SW Registration ExitCode 0  -- expecting 0
      SW  Workbench PlugIn ..... Configure Success

      SpaceClaimEngineeringConfiguration Not Detected

      Saving to C:\Program Files\ANSYS Inc\v222\commonfiles\CAD\CADConfigurationInfo.XML
      Writing to C:\Program Files\ANSYS Inc\v222\commonfiles\CAD\CADConfigurationInfo.XML
      WriteUpdateConfigurationStatusFile Update Success


      Thanks!

      Ryan

    • ryan-feeley
      Subscriber

      Fyi, Solidworks has a "fast startup" feature (which I've disabled), but could make the above step "Make sure NO software is running: Solidworks or ANSYS" a little hard to achieve for some users.

      I'm pretty sure I had all the relevant programs closed when I did the above procedure.

      After doing the Speos Geometry Update (which may still be using 2021 based on the licensing pop-up), I see the following from Speos status history. The two red ! are unexpected.

    • ryan-feeley
      Subscriber

      Just as a follow-up, the above procedure described by George may have worked. I tried multiple times to unconfigure the Solidworks Workbench plugin for both "all users" and "current user (admin)". Every time I relaunched the CAD Configuration Manager, it appeared to reselect the "Workbench Associative Interface" radio button option, but I was able to get the Solidworks 2021 licensing requests to stop. The situation seemed a little shaky though, so I went ahead and temporarily uninstalled Solidworks 2021 to make sure Solidworks 2020 would be used for the geometry update.

      Thanks for your help George!

    • asfand ali
      Subscriber

      kindly have solid solution?

      Ask by NameCombiner

Viewing 5 reply threads
  • You must be logged in to reply to this topic.