Electronics

Electronics

How to simulate SBR+ rays passing through transparent materials in HFSS?

    • Jamieu
      Subscriber

      The Problem: HFSS SBR+ Ray Tracing seems to only reflect rays at the interfaces between materials.

      More Detail: I am simulating a dielectric lens in HFSS. Using SBR+ ray tracing, the rays seem to be entirely reflected off the surface of the lens – and all interfaces between transparent materials for that matter. I am using default material definitions provided by Ansys for the Teflon Lens and Air box. In our mm-wavelength range, Teflon should be relatively transparent.

      Question: How do I use SBR+ ray tracing to simulate how the lens directs the light waves? What settings should I change so that the rays pass through object interfaces instead of being entirely reflected?

      Thank you

    • Praneeth
      Ansys Employee

      Please check whether transmitted rays are selected in the filters provided.
      To validate for the correctness of the materials, you can try changing the material for the lens with air and see whether you are getting desired results or not.
      All the very best.
    • Jamieu
      Subscriber

      Thank you for your response.
      Fist suggestion: In the "Modify SBR VRT Plot" window under "Shoot Filer", for "Filter Type" I only see four options: "All Rays", "Rays by Index", "Rays in box", and "Single ray". I don't see an option for "Transmitted rays". Where can I find an option to select transmitted rays?
      Second suggestion: To your suggestion of swapping out the material of the lens, the rays still seem to be completely reflected off of objects surfaces. I tried setting the lens material to air, and still rays were reflected off of the object's surface. This was even the case when the air lens is placed in a box of air.
      Trying a simpler case: I made a file that is simply a box of air, and still all rays are reflected off its surface.
      Do you have more suggestions of ways to resolve this transmittance problem?
      Thank you Jamie
Viewing 2 reply threads
  • You must be logged in to reply to this topic.