Ansys Products

Ansys Products

icemcfd will not launch


    • rachael.auch

      Creating a new discussion as I have not had a resolution on an earlier issue. Also editing to add that we have tried this with a newer version of Ansys (2020 R1) with similar result so it appears to be system related.

      I am using icemcfd with Ansys 19.3. When I launch icemcfd it is very slow to load, sometimes taking up to 3-5 minutes.

      The OS is CentOS 7.

      I am using environment modules to load the software. This is the environment module.

      set    topdir         /home/ansys2019r3/

      set    version        v195

      prepend-path PATH     $topdir/$version/ansys/bin

      prepend-path PATH     $topdir/$version/Framework/bin/Linux64

      prepend-path LD_LIBRARY_PATH $topdir/$version/Framework/bin/Linux64/Mesa

      prepend-path PATH     $topdir/shared_files/licensing/lic_admin

      prepend-path PATH     $topdir/$version/home/ansys2019r3/v195/fluent/bin

      setenv ANSYS182_DIR    $topdir/$version/ansys

      setenv ANSYSLIC_DIR    $topdir/shared_files/licensing

      prepend-path   PATH   $topdir/$version/fluent/bin

      prepend-path   PATH   $topdir/$version/icemcfd/linux64_amd/bin

      setenv ICE_ACN        $topdir/$version/icemcfd/linux64_amd

      prepend-path   PATH   $topdir/$version/autodyn/bin

      prepend-path   PATH   $topdir/$version/Framework/bin/Linux64

      prepend-path   PATH   $topdir/$version/polyflow/bin

      Once I type in 'icemcfd' it hangs on ICEM_ACN is "/home/ansys2019r3/v195/icemcfd/linux64_amd" and eventually after 5 minutes the software will launch.

      Eventually when it does load I get this output on the command line:

      LD_LIBRARY_PATH is "/home/ansys2019r3/v195/icemcfd/linux64_amd/lib






      args =

      Window information: depth = 24

                         class = 4

      visual depth = 32 class = 4

      can't load font screen14, using variable

      can't load font symbol14, using variable

      can't load font symbol18, using variable

      can't load font symbol24, using variable

      Graphics system = OglDL


      I am not sure what else to troubleshoot. This is a clean installation. I also have the same issue with an existing install on another CentOS 7 machine. Same version of Ansys.

      I have tried it without the environment module and I get the same result.

      Thanks for any assistance.

    • ANSYS_MMadore
      Ansys Employee
      Could you try without specifying your own LD_LIBRARY_PATH? What is the latency with the license server? Do other applications launch in this environment without issue? This could be graphics related, could you share the results of these commands?nglxinfo -display :0 | grep -i opengl.versionnexport LIBGL_DEBUG=verbose glxgearsnexport LIBGL_DEBUG=verbose glxinfonlspci -vnn | grep VGA -A 12nnvidia-sminnvidia-settings -q NvidiaDriverVersiovidia-settings -q allnnThanks,nMattn
    • rachael.auch
      Array nThanks for the reply. nTried without specifying our own LD_LIBRARY_PATH, no change. No issues with the license server. Other applications can launch in this environment without any problems. Right now it seems to just be ICEM-CFD. nThis just seems to be domain accounts only that this is affecting as well. This Linux server is joined to a Windows AD domain. Icem-cfd opens just fine for root and also for a local account. I used 'env' to compare the environment variables between my account and a local account as a test, there is no considerable difference. nIn playing around with the icemcfd launch script, default location: /ansys_inc/v195/icemcfd/linux64_amd/bin I commented out the following lines:# (re)set limits for at least OSF1 and AIX41n#if ( id | sed 's/^[^=]*=/;s/[( ].*$/' == 0) thenn   # root must not unset the limits onn   # various operating systemsn#   echo 'Hallo root.'n#elsen#   set uname_r= uname -r n#   set uname_s= uname -s n#   if ( $uname_s != Linux && expr $uname_r : B.11* < 4) thenn#       unlimitn#   endifn#endifnnAnd this seems to have resolved the problem for my domain account and one other. One other person is still having issues however, I need to do some further troubleshooting with that person, but I do not know why that would make a difference but it has cut the time to open the program down to ~5 seconds from 5 minutes. nThis is the output for the commands suggested:glxinfo | grep -i opengl.versionnOpenGL version string: 2.1 Mesa 18.3.4nnlspci -vnn | grep VGA -A 12n0a:03.0 VGA compatible controller [0300]: Matrox Electronics Systems Ltd. MGA G200eW WPCM450 [102b:0532] (rev 0a) (prog-if 00 [VGA controller])n       Subsystem: Dell Device [1028:0444]n       Flags: bus master, medium devsel, latency 64, IRQ 20, NUMA node 0n       Memory at e5800000 (32-bit, prefetchable) [size=8M]n       Memory at eeffc000 (32-bit, non-prefetchable) [size=16K]n       Memory at ee000000 (32-bit, non-prefetchable) [size=8M]n       [virtual] Expansion ROM at ee800000 [disabled] [size=64K]n       Capabilities: n       Kernel driver in use: mgag200n       Kernel modules: mgag200n20:00.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD/ATI] RD890 Northbridge only dual slot (2x8) PCI-e GFX Hydra part [1002:5a12] (rev 02)n       Subsystem: Dell Device [1028:0444]nnThere is no video card in the system. Would appreciate any ideas. Thank you,
    • ANSYS_MMadore
      Ansys Employee
      This machine lacks a supported graphics device and is not supported for running the UI of our applications. While you may see it work, it's unsupported.n
Viewing 3 reply threads
  • You must be logged in to reply to this topic.