Ansys Products

Ansys Products

Installing LINUX version of ANSYS 2019 R2 Electronics Desktop

    • raul
      Subscriber

      I am trying to install ANSYS 2019 R2 Electronics Desktop, on a RedHat-like Linux operating system. 


      When I type:   ./install


      a windows appear, with a few options available. I click on "Install Electromagnetics Suite".


      A smaller windows appears, with some text that starts with "Preparing InstallShield wizard". Also, a percentage number is shown. When the percentage reaches "60% complete", it stops, and another windows appears.


      This windows says:


      "3J


      This application requires a Java Run Time Environment (JRE) to run", and more


      I do have the Oracle JRE as my active Java environment. I have also tried activating the OpenJDK, but no look.


      When I type "./install", I have also pointed to the java folders using "-is:javahome". But this does not help.


      I have also tried to do the installation from the "Linux/AnsysEM/disk1" folder, by typing "./setup.exe", but the same problem happens.


       


      I do not know what else to do. I really need help with this.


      Any help would be greatly appreciated.


       


      I attach a screenshot.


       


      Thank you!


      Raul


       


       


       


       


       


       


       


       


       


       

    • tsiriaks
      Ansys Employee

      Hi Raul,


      Our installer uses JRE that's embedded inside the installation package. The fact that the installer doesn't see it leads me to think that you might be missing some prerequisites.


      Can you try


      yum install redhat-lsb


      and see if that makes any differences ?


      Thanks,


      Win

    • raul
      Subscriber

      Thank you very much Win,


      I tried your suggestion, but the redhat-lsb package is already installed:


       


      "Package redhat-lsb-4.1-45.x86_64 is already installed.


      Dependencies resolved.


      Nothing to do.


      Complete!"


       


      when I go back to install the Electronics Desktop I still get the JRE problem


      Thanks again for your support.


      Raul


       


       


       


       


       

    • tsiriaks
      Ansys Employee

      Hmmm. What is the output of


      cat /etc/*release


      Also, please check the AnsysEM installation guide Chapter 1 and make sure that you have all prerequisites listed there installed.


      Thanks,


      Win

    • raul
      Subscriber

       


      Hi Win,


      Reading the Installation Guide Chapter 1, it seems that the requirements are 32-bit libraries. Am I supposed to have those installed on a 64-bit OS ?


      below is the output of cat /etc/*release.  


      I am aware that Fedora is not officially supported, but still would have expected to be able to install the ANSYS software.


      Thanks again!


      Raul


       


       


      Fedora release 29 (Twenty Nine)


      NAME=Fedora


      VERSION="29 (MATE-Compiz)"


      ID=fedora


      VERSION_ID=29


      PLATFORM_ID="platform:f29"


      PRETTY_NAME="Fedora 29 (MATE-Compiz)"


      ANSI_COLOR="0;34"


      CPE_NAME="cpeo:fedoraproject:fedora:29"


      HOME_URL="https://fedoraproject.org/"


      DOCUMENTATION_URL="https://docs.fedoraproject.org/en-US/fedora/f29/system-administrators-guide/"


      SUPPORT_URL="https://fedoraproject.org/wiki/Communicating_and_getting_help"


      BUG_REPORT_URL="https://bugzilla.redhat.com/"


      REDHAT_BUGZILLA_PRODUCT="Fedora"


      REDHAT_BUGZILLA_PRODUCT_VERSION=29


      REDHAT_SUPPORT_PRODUCT="Fedora"


      REDHAT_SUPPORT_PRODUCT_VERSION=29


      PRIVACY_POLICY_URL="https://fedoraproject.org/wiki/LegalrivacyPolicy"


      VARIANT="MATE-Compiz"


      VARIANT_ID=matecompiz


      Fedora release 29 (Twenty Nine)


      Fedora release 29 (Twenty Nine)


       

    • tsiriaks
      Ansys Employee

      Hi Raul,


      Yes, you also need those 32-bit libraries to be installed.


      Hopefully, that helps; otherwise, Fedora is going to be the prime suspect here.


      Thanks,


      Win

    • FHRAEM
      Subscriber

      Got the same error with opensuse Leap 15.0. and Fedora - using the Cinnamon desktop.


      Maybe I'm wrong but it could be a problem with the desktop installed (mate/cinnamon) ?


       


       


       


      Hi Raul,


      Yes, you also need those 32-bit libraries to be installed.


      Hopefully, that helps; otherwise, Fedora is going to be the prime suspect here.


      Thanks,


      Win


    • raul
      Subscriber

      Hi FHRAEM


      Thank you very much for your information. 


      I was finally able to solve the issue. The problem was most likely the fact that I used Fedora Mate.


      I changed the operating system to CentOS 7 and I was able to install and use HFSS.


      Specifically, (1) First I installed CentOS 7 with its standard desktop environment (Gnome 3). (2) Then I installed HFSS and it worked.  (3) Then I installed the Mate Desktop.  (4) Then I checked if HFSS would still work when logging in with Mate instead of Gnome 3, and it did


      Cheers


      Raul


       


       


       


       


       

Viewing 7 reply threads
  • You must be logged in to reply to this topic.