Ansys Products

Ansys Products

Discuss installation & licensing of our Ansys Teaching and Research products

Installshield Wizard blocks during installation of Electronic Desktop on Centos 7

    • tomas.monopoli


      I am trying to install Ansys Electronic Desktop on a Centos 7 operating system.

      I installed the reuirement packages specified in the installation guide. When I run the install file in the download, the installation shell opens correctly. However when I click on install EM suite, the process blocks at the following step:

    • randyk
      Ansys Employee
      Hi Tomas I'd suggest you use a silent installation mode.

      To install Ansys Electronics uses InstallShield.
      These are the generic steps I tend to recommend for AEDT silent install on Linux
      1.. extract AEDT media to /tmp
      2.. create/edit /tmp/AEDT/silAEDT.iss
      $ cp /tmp/AEDT/Electronics_xxx_linx64/Linux/AnsysEM/disk1/SilentInstallationTemplate.iss /tmp/AEDT/silAEDT.iss
      line 46:-W GroupPanel.groupID="root"
      line 69: -P installLocation="/opt/AnsysEM"
      line 81: -W TempDirectory.tempPath="/tmp"
      3.. install
      $ /tmp/AEDT/Electronics_xxx_linx64/Linux/AnsysEM/disk1/setup.exe -options "/tmp/AEDT/silAEDT.iss" -silent
      4.. fix license and tempdirectory
      When complete edit the following files to specify correct license and tempdirectory:
      5.. To run AnsysEM /AnsysEMxx.x/Linux64/ansysedt

      If need AnsoftRSMService, that is done by:
      Create the /tmp/rsm.iss(correct path and owner as needed)
      -W Agree.selection=1
      -W GroupPanel.groupID="root"
      -P installLocation="/opt/AnsysEM"
      Run the following:
      sudo /path/Electronics_xxx_linx64/Linux/RSM/disk1/setup.exe -options "/tmp/rsm.iss" -silent
      sudo /opt/AnsysEM/rsm/Linux64/ansoftrsmservice startonboot
      -- register AnsysEM so AnsoftRSMService can find the solver/comm engines.
      sudo /opt/AnsysEM/AnsysEMxx.x/Linux64/ add

      To silent install theV22r1.2 patch in Linux
      $ tar -xzvf ./
      $ cd //AnsysEM/Electronics_22.1.2_linx64
      $ ./install_patch.bash --force_overwrite --install_dir //AnsysEM
      $ cat //AnsysEM/v221/Linux64/
      should result in:

      AnsProductName="ANSYS Electromagnetics"
      AnsProductBuildDate="2022-02-23 19:11:24"

      Hope this helps

    • tomas.monopoli
      Thank you vary much for your answer Randy.

      I installed AEDT following the steps you described.

      I get an error:
      However, if I run sudo yum install , it seems the package is already installed:
      I attach the full lld output log in case it can be useful.

      Also, I have (I think ) correctly inserted the ANSYS FLEXlm port number and Hostname for the licence in config file. However, I didn't find where to insert the ANSYS Licencing Interconnect Port Number.

      Thank you Tomas

    • randyk
      Ansys Employee
      Hi Tomas Please try: sudo yum install -y libXScrnSaver
      After, confirm the library is in place: ls -al /usr/lib64/libXss*
      -bash-4.1$ ls -al /usr/lib64/libXss*
      lrwxrwxrwx. 1 root root15 Dec 132016 /usr/lib64/ ->
      -rwxr-xr-x. 1 root root 13520 Feb 212013 /usr/lib64/

    • tomas.monopoli
      Thank you very much! The installation now works correctly :)
    • Madison Le

      I had this same issue with the InstallShield limiting the AnsysEM pop-up window. I was able to resolve this by adjusting my display settings from Landscape Orientation to Portrait Orientation & then the GUI launched fully! 

Viewing 5 reply threads
  • You must be logged in to reply to this topic.