Fluids

Fluids

Issue with running Fleunt in batch mode.

    • Rashi
      Subscriber
      Hi all,nI've trying to run a simulation in Compute Canada HPC by executing a journal file. nI have set the autosave option at every five iterations. However, after the fifth iteration, the simulation stops with the following error.nError: Hdfio library can be only loaded in parallel.nError: Hdfio library can be only loaded in parallel.nError Object: #fnWarning: An error or interrupt occurred while reading the journal file.nSome commands may not have been completed.nnThe journal file which I executed is as following,n; lines beginning with a semicolon are commentsn; Read only the input case file:n/file/read-case lattice.cas.gzn; In case of a continuation, you need to read both .cas and *.dat; /file/read-case-data lattice.cas.gzn; Write a data (and maybe case) file every 1 time steps:n/file/auto-save/data-frequency 5n/file/auto-save/case-frequency if-case-is-modifiedn; Write to output sub-directory (appends flowtime and timestep)n/file/auto-save/root-name output/lattice-out-%10.6f.gzn; # Set the number of iterations for which convergence monitors are reported:n/solve/set/reporting-interval 1n; ##### End of settings for Transient simulation. ######n; Initialize using the hybrid initialization method:n/solve/initialize/hyb-initializationn; Patching cell zones with initial temp: n/solve/patch fluid () temperature 1688n/solve/patch solid () temperature 673n; ##### settings for Transient simulation : ######n; # Set the magnitude of the (physical) time step (delta-t)n/solve/set/time-step 0.00001n/solve/set/max-iterations-per-time-step 20n/solve/dual-time-iterate 800000n/plot/residuals-set/plot-to-file residuals.txtn; write the output (both FFF-transient-out.cas.gz and FFF-transient-out.dat.gz):n/file/write-case-data lattice-out.cas.gzn; Write simulation report to file (optional):n;/report/summary y Report_Transient_Simulation.txtn; Exit fluent:nnFurthermore, in order to output the residuals I've tried using /plot/residuals-set/plot-to-file residuals.txt TUI command but it just gave me a blank file.nnThank you.nBest Regards,nRashin
    • Keyur Kanade
      Ansys Employee
      Quick check - nOpen Fluent and try to run each command one by one. You can copy paste the command in Fluent TUI. This will make sure that journal file commands are correct. n
    • Rashi
      Subscriber

      Quick check - Open Fluent and try to run each command one by one. You can copy paste the command in Fluent TUI. This will make sure that journal file commands are correct.https://forum.ansys.com/discussion/comment/112095#Comment_112095

      Thank you for your suggestion. I tried it but the TUI works in GUI mode but does not work in batch mode.n
    • Rob
      Ansys Employee
      Is Compute Canada a LINUX/UNIX system? n
    • Rashi
      Subscriber

      Is Compute Canada a LINUX/UNIX system?https://forum.ansys.com/discussion/comment/112551#Comment_112551

      Hi Rob,nYes, it uses Linux/Unix system.nI also noticed that each time I execute 'write-case-data' command I get the above-mentioned error. However, when I export text-based results, let's say temperature data to a text file it works without any issue.nFirst I thought the problem may be due to not having to write access, but it seems it is not the case.
    • YasserSelima
      Subscriber
      ArraynI have a question about the license of Compute Canada ... Are you using your own license or their license? if their license, how long do you wait before running your simulation on average?n
    • Rob
      Ansys Employee
      If you're using 2021R1 check the local set up re h5 files, you might be trying to force that. I'd also get rid of any spaces in the file path and name. LINUX is really not happy with spaces etc. n
    • Rashi
      Subscriber
      yes, we are using a license from CMC microsystems. Unfortunately, I haven't tried with their own license.ndue to licensing issues I'm using 2020 R2. Will, it possible to know how to check the re h5 files? Also, I not sure if I have access to those since I do not have admin privileges. I can open a support ticket and ask them, but I'm not sure what should I ask them exactly.
    • YasserSelima
      Subscriber
      ok, I know they have limited number of licenses and I was wondering about the Q time. Thanks!n
    • DrAmine
      Ansys Employee
      Check the preferences under File and disable there CFF to keep writing legacy Fluent files.n
    • Rashi
      Subscriber

      Check the preferences under File and disable there CFF to keep writing legacy Fluent files.https://forum.ansys.com/discussion/comment/112706#Comment_112706

      @DrAmine, I do not have access to GUI since I'm running fluent in batch mode in an HPC.n
    • DrAmine
      Ansys Employee
      Same can be done under file preferences from TUI or you store the preferences in your home directory (folder starting with .fluentconf)n
    • Rashi
      Subscriber

      Same can be done under file preferences from TUI or you store the preferences in your home directory (folder starting with .fluentconf)https://forum.ansys.com/discussion/comment/112723#Comment_112723

      @DrAmine, it's still not working nI used /preferences/general/default-ioformat 'Legacy' TUI command, and I get the following error.nSo I gave up and used Ansys 2019R3 which worked finally, but now I get the following error which stops the simulation before it starts.
      'Error: Update_Time_Level: invalid datanError: Update_Time_Level: invalid datanError Object: #f'
    • YasserSelima
      Subscriber
      Look herenhttp://www.cfdresearch.com/ansys-fluent-solutions/
    • Rashi
      Subscriber

      Look herehttp://www.cfdresearch.com/ansys-fluent-solutions/https://forum.ansys.com/discussion/comment/112876#Comment_112876

      Hi @YasserSelima, , thank you for your reply. Unfortunately, this method did no. The simulation only ran the first iteration and then stopped. Because of this, I recreated the simulation and created the journal and case file which solved the issue. n
Viewing 14 reply threads
  • You must be logged in to reply to this topic.