Ansys Products

Ansys Products

Linux Installation Does not Allow me to use more than 4 cores

    • tomas.monopoli
      Subscriber

      I have installed Ansys on a Linux Centos 7 machine with 12 cores. However, if I increase the number of cores to use in the HPC options I get the following error when starting the analysis:

      not enough HPC parallel licences 12/4

      However, I have installed AEDT on other windows machines and regularly use more than 4 cores with my current licence. 

      Can anybody help? I installed AEDT on the linux machine with a silent install.. could this be a clue as to what went wrong?

       

      Thank you
      Thank you!

    • George Karnos
      Ansys Employee

      What Ansys Program can not use more than 4 cores?
      Can you post a license status from your License server as to see which licenses are available?

    • tomas.monopoli
      Subscriber

      The program I am using is HFSS.

      If I run a Licence Status this is what I get:

      However, in general, the licence works on all windows machines and also on the linux up to 4 cores. 

    • George Karnos
      Ansys Employee

      What is the license status on the Windows machines that can use more than 4 cores?

    • tomas.monopoli
      Subscriber

      Unfortunately I get the same error on the windows machines if I try to run a licence status.

       

    • Randy Kosarik
      Ansys Employee

      Hi Tomis,

      I suspect your Linux installation is set to the wrong HPC license type.

      Please review the contents of: //AnsysEM/shared_files/licensing/ansyslmd.ini
      There will be a "SERVER" line that references a port@licenseservername
      Using that port@licenseservername reference, run the following (correct highlighted):
      //AnsysEM//Linux64/licensingclient/linx64/lmutil  lmstat  -i  -c  port@licenseservername  |  grep  -i  hpc

      If that fails, please reach to your license administrator and request they provide the type of HPC licensing - it will either be  "anshpc" or "anshpc_pack"
      Set the "HPC Licensing" value -- in "HPC and Analysis Options" -> "Options" tab to reference the appropriate Pool or Pack.

      thanks
      Randy

Viewing 5 reply threads
  • You must be logged in to reply to this topic.