Ansys Products

Ansys Products

LS Dyna license server error when moved to container infrastructure

    • jclark
      Subscriber

      I am placing this here since there doesn't appear to be a dedicated LSTC category yet. I have been attempting to get help now for about 3 weeks on this issue but am now asked to post here before anything else will be done. 😶

      From the initial part of a long email chain.

      > We are currently unable to run the lstc license manager since moving our  

      > license server to a new OS and platform. I would like to find out if  

      > there is something available that will work (newer license manager    

      > perhaps) or if you could help troubleshoot the issue.  

      >   

      > This was working on our old platform but does not start now after the  

      > following changes:  

      >                                                                 

      > OS: CentOS 6 -> CentOS 7  

      > server platform: KVM virtual machine -> lxd container under proxmox                                                                                   

      > Error message received when trying to start:            

      > *********************************************************************   

      > LSTC license server version 77918 started at Fri Apr 30 15:28:18 2021  

      > *********************************************************************  

      > Using configuration file /var/lmgrd/ls_dyna.test/server_data  

      > ERROR: the host id(s) of this machine ( 0A5367CC )  not found in the license file /var/lmgrd/ls_dyna.test/server_data


      this line from the generated license file

      SERVER: 0A5367CC 2E83BD83 22F06842 1443FB17 488A8E2E

      shows the "missing" hostid as the first entry.

      Then had a new license file generated from a newly created LSTC_SERVER_INFO file and still get the same error. Anyone have the license server running under a similar infrastructure? And yes, we have had the server running on a VM that has been migrated from host to host for years without any issues and are currently running 17 other network licenses on the server container that is giving us issues with ls dyna (the only one not working at the moment).

      Thanks for any help provided.

      Jim

    • TrentE
      Ansys Employee
      The LST License Manager is keyed to the underlying physical hardware. So, if you put the license manager in a VM, and if you move that VM to different underlying hardware, the LST License Manager is almost surely going to stop working at some point. And, at that point, you'll need to generate a new LSTC_SERVER_INFO file and send that along with the existing license file to your ANSYS Account Manager. Request a Server Change. Otherwise, move the VM back to the original hardware and restart.
    • jclark
      Subscriber
      Thanks Trent but that does not seem to be the issue here and doesn't follow actual experience.
      Before creating the new server container we were running the license server on a kvm VM for years and migrating it among 5 hosts during maintenance on an ongoing basis. Never had an issue with the hos id changing or the service not starting. But, maybe that won't work with the server as a container. So, I requested a new license file using the data file generated on the new system. With the new license the service still does not start even though the container is on the same host and has not been restarted since the LSTC_SERVER_INFO was generated. My guess is the method used to generate the keys does not play well with the server as a container. The fact that the error complains about not finding the host id that is listed first in the license file suggests something is out of whack.
      But, I have had users without access now for about a month so yesterday I requested a Server Change and will be moving the server to a Windows VM running in a standard configuration.
      Thanks again.
    • TrentE
      Ansys Employee
      You're welcome. Thanks for your patience. In these cases, generate a new LSTC_SERVER_INFO file in the container where you are seeing a failure of the server to start. Compare the SERVER lines with those in the license file. If there's no match, then the server will not start. That should help you debug.
    • jclark
      Subscriber
      Just for completeness in case someone in the future runs into a similar issue.
      Here is the attempted start for the server, manually to capture all the output
      -----------------------------------
      [root@perseus ls_dyna]# su - flexlm -c "/var/lmgrd/ls_dyna/lstc_server -D -f -l /var/lmgrd/ls_dyna/lstclm.log"
      Changing to security directory /var/lmgrd/ls_dyna
      Got Args
      Using configuration file /var/lmgrd/ls_dyna/server_data
      Reading data file /var/lmgrd/ls_dyna/server_data
      back from readfile, rc=0
      My host id a5367cc
      Checking host a5367cc
      ERROR: the host id(s) of this machine ( 0A5367CC )
      not found in the license file /var/lmgrd/ls_dyna/server_data
      --------------------------------------------
      Here are the SERVER lines from our various license files and LSTC_LICENSE_INFO generated files.
      old, working license - SERVER: 0A5367CC 2E83BD83 22F06842 1443FB17 488A8E2E
      newly generated info file, container, first host - SERVER: 0A5367CC 2E83BD83 22F06842 1443FB17 488A8E2E
      newly generated info file, container, second host - SERVER: 0A5367CC 2E83BD83 22F06842 1443FB17 488A8E2E
      As you can see, the host id keys are identical in all instances but the error still complains about the host id not found.
    • TrentE
      Ansys Employee
      However it is that you run lstc_server to generate the LSTC_SERVER_INFO file, you'll need to run the lstc_server with the server_data license file generated using the LSTC_SERVER_INFO file. If you run "lstc_server info" in one environment and you run the lstc_server with the newly created license file in another, that won't work.
Viewing 5 reply threads
  • You must be logged in to reply to this topic.