LS Dyna

LS Dyna

Topics relate to LS-DYNA, Autodyn, Explicit STR and more

LS-Dyna UMAT compilation issue (Intel Fortran Compiler 19.0)


    • Oleg Makarov

      Dear colleagues!

      I am trying to include UMAT in my numerical model and I have issues with compiling LS-Dyna R14 object version.

      Firstly I tried to use Microsoft VS 2022 + latest oneAPI. When I used ‘nmake’ to compile LS-Dyna executable I got some error (don’t remember the exact logs).

      Secondly, I saw this post and your recomendation to install Inter Fortran Compiler 19.0. Therefore I uninstall all abovementioned software, reinstall Win10, and installed VS 2015 + Intel Parallel Studio XE Cluster Edition 2019 Update 5 (Intel Fortran compiler 19.0). But unfortunately, I am still not able to compile the LS-Dyna executable. When I use ‘nmake’ in the command window I receive the following Error:

      /opt/intel/compilers_and_libraries_2019/linux/bin/intel64/ifort -sox -o lsdyna ./obj/init_once.o ./obj/init_dyn21.o ./obj/dynm.o ./obj/banner.o ./obj/sec.o ./obj/dyn21.o ./obj/dyn21umat.o ./obj/dyn21umats.o ./obj/dyn21umatv.o ./obj/dyn21umatc.o ./obj/dyn21tumat.o ./obj/dyn21utan.o ./obj/dyn21ueos.o ./obj/dyn21cnt.o ./obj/dyn21ushl.o ./obj/dyn21usld.o ./obj/dyn21extumat.o ./obj/dyn21em.o ./obj/dyn21icfd.o ./obj/couple2other_user.o ./obj/dynrfn_user.o ./obj/adummy_graph.o ./obj/orderByMetis.o ./obj/mod_impl_matrices.o ./lib/libdyna.a ./lib/libbcsext4.a ./lib/liblsda.a ./lib/liblsdb.a ./lib/liblssecurity.a ./lib/liblcpack.a ./lib/libmf2.a ./lib/libspooles.a ./lib/liblcpack.a ./lib/libspooles.a ./lib/libcparse.a ./lib/liblsm.a ./lib/liblscrypt.a ./lib/libresurf.a ./lib/libdsa.a ./lib/liblsmc.a ./lib/libsfg.a ./lib/libevl.a ./lib/libcminpack.a ./lib/libzmumps.a ./lib/libdmumps.a ./lib/libmumps_common.a ./lib/libmumps_mpiseq.a ./lib/libmetis.a ./lib/libim_rotor_dynamics.a ./lib/libarpack.a ./lib/libmcms.a ./lib/liblso.a ./lib/libunits.a ./lib/libem.a ./lib/libfemster_wrap.a ./lib/libfemster_wrap2d.a ./lib/libfemster_wrap1d.a ./lib/libfemster.a ./lib/libfemster2d.a ./lib/libfemster1d.a ./lib/libpfem.a ./lib/libcese.a ./lib/libchemistry.a ./lib/libem_tailsit.a ./lib/libem.a ./lib/libparticles.a ./lib/libeosfl2.a ./lib/libpfem.a ./lib/libmoving.a ./lib/libdualcese.a ./lib/libbattery.a ./lib/libfftw3.a ./lib/libfftw3_omp.a ./lib/libansysl.a ./lib/libdyna.a ./lib/libmetis.a ./lib/libspooles.a ./mkl/libmkl_intel_ilp64.a ./mkl/libmkl_intel_thread.a ./mkl/libmkl_core.a ./mkl/libmkl_intel_ilp64.a ./mkl/libmkl_intel_thread.a ./mkl/libmkl_core.a ./mkl/libmkl_intel_ilp64.a ./mkl/libmkl_intel_thread.a ./mkl/libmkl_core.a -qopenmp-link=static -static-intel -qopenmp -lrt -lstdc++ -lpthread -lstdc++ -lpthread

      The system is unable to find the specified path.

      NMAKE : fatal error U1077: : returned code “0x1″ Stop.

      Why it is not working? How can I fix this issue?

    • Ushnish Basu
      Ansys Employee

      This is already being discussed here

Viewing 1 reply thread
  • You must be logged in to reply to this topic.