General Mechanical

General Mechanical

Mechanical – Contact Body View not Showing Anything

    • Lyster
      Subscriber

      I'm fairly new to Ansys and was just working through one of th tutorials and noted a possible display issue.

      Nothing shows up in contact body view even though the bodies are there as they are selectable, refer to picture.

      Is there something I'm missing.

    • Akshay Maniyar
      Ansys Employee

      I am not sure why this is happening. Can you try to click on other contact and click on zoom to selection. Make sure that no bodies are hidden.

      Thanks amaniyar
    • Lyster
      Subscriber

      Thanks for your reply. I've tried what you've said and confirmed there are not bodies hidden and there's no change.
    • Akshay Maniyar
      Ansys Employee

      Can you try resetting APPDATA folder.
      Step 1: Close all Workbench sessions
      Step 2: Type %appdata% in the search field of Windows
      Step 3: Open the folder named Ansys
      Step 4: Locate the folder corresponding to your installation, for instance if you are having error with R19.0 installation, then locate the folder named v190 (similarly, locate v191 for R19.1).
      Step 5: Rename this folder as v190_old and start a new WB session.
      This will create a fresh copy of the v190 folder (which contains WB environment files) and resolve such issues. The procedure is same for different versions of WB so you just need to rename the appropriate folder.
      Thanks amaniyar
    • Lyster
      Subscriber

      Thanks again for your reply. I've completed all you've said and it was the same result.


    • Gary_Lozik
      Subscriber
      I have similar problem only for Ansys2021
    • Gary_Lozik
      Subscriber
      It is looks like Ansys 2021 setting. the same model in Ansys 2019 working perfect and shows contact and target bodies in appropriated windows

    • Lyster
      Subscriber
      Thanks for the confirmation . sounds like a bug, is there way to register it as bug to get it rectified?
    • Akshay Maniyar
      Ansys Employee

      I have checked it on my system and with same model(the screenshot I have attached above), it is working fine.
      Is it happening with all the model you are working ? What kind of license you are using?
      Can you try updating your graphics driver, and see if issue still occurs?
      Thanks Amaniyar
    • Akshay Maniyar
      Ansys Employee

      We have a known issue with some AMD cards causing the body view window to be blank. We are working to resolve this hopefully by the next release. In the meantime, you can set this Windows environment as a workaround:
      ANS_USE_202_GRAPHICS_DRIVER = 1


      Thanks Amaniyar
    • Sebastian Ramos-Roux
      Subscriber

      I have tried implementing this workaround by going into "Advanced System Settings" > "Environment Variables" and adding a new variable titled "ANS_USE_212_GRAPHICS_DRIVER" under "System Variables" and setting the value to 1, however it is not making any difference in my ability to see the contact bodies. Am I doing something wrong?

Viewing 10 reply threads
  • You must be logged in to reply to this topic.