Fluids

Fluids

Mesh adaption problems

    • soloviev
      Subscriber

      Hello,


      I am working with a VOF-to-DPM model to explore how the ocean interface behaves under hurricane winds. I am having some trouble with the mesh adaption. I am using the gradient of water volume fraction as my parameter for adaption with the refine threshold of 0.5 (normalized). I have tested a case with a flat-water surface and it seems to adapt only at the air water interface, which is what should happen. I am now testing a wavy water surface and the adaption occurs in the entire water phase. The only difference between the case setups is that I have initialized a wavy surface. Do you have any ideas on what could be causing this improper mesh adaption?


      Thank you,


      Alex

    • Keyur Kanade
      Ansys Employee

      Can you insert some images?


      How is the behaviour with wavy surface without adaption? 


      Can you please insert images of your mesh and set up?


       

    • soloviev
      Subscriber

      Hello,


      I have previously run cases with a similar mesh (without adaption) and similar waves and everything behaved as expected. I have attached several figures showing my problem with the mesh adaption. These figures all show the center plane of the domain with the mesh visible. In the initial condition, the mesh is just refined at the air-water interface (see figures “wavy_init_VF_mesh” and “wavy_init_mesh&rdquo. After just two time steps the mesh has refined several times in the entire water layer (see figures “wavy_2step_mesh.png” and “wavy_2step_VF_mesh.png&rdquo.


      One thing that I just noticed about the mesh adaption. When I set up the adaption, I choose the adaption based on the volume fraction of water. However, in the TUI, it says that the adaption is based on the gradient of pressure. Why would this change?


      Thank you,


      Alex

    • Keyur Kanade
      Ansys Employee

      As ANSYS employees, we can not download attachments. Can you please insert images so that we can see it. 

    • soloviev
      Subscriber

      Of course. The images are below


      Mesh at the initial time


      Initial mesh and contour of volume fraction


      Mesh after two time steps


      Mesh and contour of volume fraction after two time steps

    • Keyur Kanade
      Ansys Employee

      when you set adaption based on vof, did you click on 'Apply'? 


      did you click on 'Coarsen'? did you give value for coarsen threshold? 


      what are parameters used in gradient adaption panel? can you please insert an image? 

    • soloviev
      Subscriber

      Hello,


      I apologize for the delayed response. 


      Yes, 'Apply' was clicked when the adaptation method was set. When running the model, the console reads that the gradient adaption is occurring on pressure, despite setting it as phases -- water volume fraction. 


      We have tried various parameters in the gradient adaption panel. We have used coarsening, and have tried various values (ranging from 0.05 to 0.4 for example) and nothing seems to allow for correct adaption. Either the adaption does not occur (reverts to starting mesh), or adapts incorrectly, such as in various places unrelated to the interface we are targeting, or refines much more than necessary, such as above, and does not adapt using the coarsening properly.


      Is there any guidance in what best practices to use to solve these issues?


      Thank you,


      Alex

    • DrAmine
      Ansys Employee

      I recommend normalising the gradients so that you just provide the threshold's independent of the range. But what about the issue with the pressure?have you setup everything within the GUI? Does the issue occur if you adapt manually instead of dynamic adaption?

    • soloviev
      Subscriber

      Hello Amine,


      The gradients are normalized when we have been running it. By manually adapting do you mean unchecking dynamic, and doing the gradient adaption from the panel throughout the process of running the model?


       


      Thanks,


      Alex

    • Rob
      Ansys Employee

       Pressure is (usually) top of the list in most panels so if you've either mis-set something or there's a problem with the panel. Amine's suggestion is to turn off dynamic adaption and see if you can adapt on the gradients manually using iso-value: this may show whether we have a problem with the solver.


       

    • Rob
      Ansys Employee

      Having checked here I suspect you need to check the Gradient Adaption panel and click on "Apply" before closing the panel.

    • soloviev
      Subscriber

      Hello,


      Thank you very much for your suggestion. After first using the iso-value adaption manually once, then running the dynamic gradient adaption is is continuing to adapt as vof. Is first manually doing it usually a necessary step to ensure it continues to do so?


      Thanks,


      Alex

    • Rob
      Ansys Employee

      No, not normally. However as your case seemed to not be keeping settings doing it manually forced the solver to update and retain the inputs. 


       


       

    • soloviev
      Subscriber

      I have another question. What is the highest maximum level of refinement that is possible? We are trying to run the model for a 22 m x 6 m x 2 m domain including the air-water interface and produce submillimeter scale spray particles in hurricane winds. This will require more than 5 levels of refinement (as was suggested for the maximum in the webinar on VOF-to-DPM model).


      Thanks,
      Alex

    • DrAmine
      Ansys Employee

      As far as I know, there is no limit there so the limiting factor is the minimum volume of a cell and your computational power / HPC availability. Though PUMA adaption might have some issues which will be enhanced. I will double check.

    • Rob
      Ansys Employee

      To add, you will need to go into the Adaption controls to increase the number of levels of refinement. The default is 2 which is to stop people creating models that are too big to run by mistake: if you know to change the value we assume you're also going to be careful! 

    • DrAmine
      Ansys Employee

      So I checked and that is what I wrote: the limiting factor is your computational power /HPC/minimum cell volume.

    • soloviev
      Subscriber

      Thank you both for your input.


      I will try increasing levels of refinement as well as minimum cell volume using your suggestions.


      Thanks, 


      Alex

    • DrAmine
      Ansys Employee

      A value of zero keeps the properties unbounded (no limit).

    • soloviev
      Subscriber

      Hello again,


      I have used your suggestions, and following this the model crashed after running out of memory. I was under the impression that Fluent was not memory intensive, but I watched the memory as the model runs, and after only 5 or so time steps, the memory usage shoots to 100% and then the model cannot run. I have attached a photo of the background processes which are taking up so much memory, and found their location which shows they are Fluent files. We already ensured that hyperthreading was not enabled on the computer. Is there a setting in Fluent that may be causing this? 


       


      Thank you very much,


      Alex

    • DrAmine
      Ansys Employee

      That is why we said that we need to be cautious with number of refinement and min cell size. Try use PUMA and not more then 2 or  3refinement levels and or restrict refinement to dedicated regions 

    • soloviev
      Subscriber

      Thank you again for the feedback. 


      We are now having a different issue. 


      The adaptive meshing does not seem to be consistent. I use the same values for refinement and coarsening, as well as the same settings. I also am using the same mesh as previously, but the mesh only adapts once, and does not continuously adapt as the water surface moves as it did in previous runs. What would cause this?


      Thank you again,


      Alex

    • Rob
      Ansys Employee

      You will need one more permitted level of adaption than you want: so if you're refining & coarsening on the same values increase the max levels of refinement to 3.  This happens because you must be able to select cells to refine before Fluent can work out coarsening. 


      This assumes the activate Dynamic setting was retained when you closed the panel. 

    • soloviev
      Subscriber

      I have done this, but it still refines only one time, and does not continue to adapt. If I go back into the mesh adaption panel and change the values, or increase the refinement, the console states that there are cells marked for refinement, but they do not refine and it simply remains the same as before. 


      thanks,


      Alex

    • DrAmine
      Ansys Employee

      Which method are you using? Hanging Node or PUMA. Are you using in conjunction with Vof to DPM?

    • soloviev
      Subscriber

      Hello,


      We are using PUMA. Yes, we are using the VOF to DPM model. 


      Thanks,


      Alex

    • DrAmine
      Ansys Employee

      Can you make a test without PUMA (hanging Nodes) just try to adapt without any physical models selected? As I said in former message the behavior for the PUMA has been enhanced with the 2019 releases.

    • soloviev
      Subscriber

      I believe we have finally gotten the mesh adaption to work properly. 


      Thank you for all of your help regarding this issue.


      Alex

    • Ibrahimabdullah
      Subscriber

      where to find the boundary adaption on ansys 2019 R2 ? thank you 

Viewing 28 reply threads
  • You must be logged in to reply to this topic.